Search found 3 matches

by kjbrock
Wed Oct 14, 2009 9:57 pm
Forum: Growl
Topic: (unknown load command 5) - 1.2 Growl-WithInstaller.framework
Replies: 6
Views: 53909

Re: (unknown load command 5) - 1.2 Growl-WithInstaller.framework

I took a look at the Growl sources, and it didn't appear that any of the deployment targets were set higher than 10.5. Some were set *lower*, but I didn't see any higher.
by kjbrock
Tue Oct 13, 2009 11:00 pm
Forum: Growl
Topic: (unknown load command 5) - 1.2 Growl-WithInstaller.framework
Replies: 6
Views: 53909

Re: (unknown load command 5) - 1.2 Growl-WithInstaller.framework

Interesting. It does successfully install and run on 10.5 if the package is built on 10.6.

I checked with otool and found that the unknown load command appears to be 0x00000022, which shows up as 'unknown' on 10.5 and as LC_DYLD_INFO on 10.6.
by kjbrock
Tue Oct 13, 2009 7:14 pm
Forum: Growl
Topic: (unknown load command 5) - 1.2 Growl-WithInstaller.framework
Replies: 6
Views: 53909

(unknown load command 5) - 1.2 Growl-WithInstaller.framework

I can't seem to build a project that uses Growl-WithInstaller.framework v1.2 with Xcode 3.1.4 on Leopard. Everything works fine if I'm building with Xcode 3.2 on SnowLeopard, but when I compile on Leopard I get the error: strip: for architecture x86_64 object: <path to GWI.framework> malformed objec...

Go to advanced search