Adium, Facebook and 10.5.6

An instant messenger which can connect to AIM, MSN, Jabber, Yahoo, and more.

Adium, Facebook and 10.5.6

Postby longdogs » Tue Dec 16, 2008 1:12 pm

Hi

Upgraded to 10.5.6 last night and it's caused problems with Safari, Adium and Facebook. I normally stay logged in to Adium all the time, and have been able to visit Facebook on the web. The two co-exist happily.

Unfortunately since I updated, when I log in to Facebook in Safari, it logs me out of Adium and vice-versa. In other words, if I use Facebook chat on Adium, I have to constantly log in to Facebook on the web, virtually every time I click a link.

Strangely, Firefox still seems to co-exist ok, but I'd rather use Safari if possible. I've re-set Safari, cleaned the cache, and emptied cookies, but nothing seems to work.

Is anyone able to use Facebook chat on Adium, and Facebook on Safari at the same time?
longdogs
Harmless
 
Posts: 2
Joined: Tue Dec 16, 2008 1:06 pm

Re: Adium, Facebook and 10.5.6

Postby monkeyman767 » Thu Dec 18, 2008 8:48 am

no i haven't even in 10.5.5. although as far as I'm aware this is documented in trac right now so I wouldn't worry. My guess though is that it is probably a safari problem as like you said firefox works fine, we may have to wait on apple for a resolution
monkeyman767
Muffin
 
Posts: 31
Joined: Wed Mar 26, 2008 6:30 pm

Re: Adium, Facebook and 10.5.6

Postby jdandrea » Sat Dec 20, 2008 1:19 pm

I had problems in 10.5.5, but it has only worsened in 10.5.6 - both for Facebook _and_ Gmail.

Disabling my Facebook login in AdiumX helped, but disabling my Gmail login did _not_ help. So ... I wonder if the culprit is not Adium or Safari per se, but rather something like NSHTTPCookieStorage in the Foundation framework?

http://discussions.apple.com/thread.jsp ... ID=8651868
http://trac.adiumx.com/ticket/11473
http://snurl.com/8xglf [developer.apple.com]
jdandrea
Harmless
 
Posts: 3
Joined: Sat Dec 20, 2008 1:00 pm

Re: Adium, Facebook and 10.5.6

Postby timotab » Sat Dec 20, 2008 10:01 pm



After reading that link, I followed one person's suggestion, and reinstalled Safari. That fixed it.
timotab
Harmless
 
Posts: 6
Joined: Mon Nov 26, 2007 11:32 pm

Re: Adium, Facebook and 10.5.6

Postby jdandrea » Sat Dec 20, 2008 11:05 pm

timotab wrote:After reading that link, I followed one person's suggestion, and reinstalled Safari. That fixed it.


Tried that. It worked ... for about 45 minutes. :(
jdandrea
Harmless
 
Posts: 3
Joined: Sat Dec 20, 2008 1:00 pm

Re: Adium, Facebook and 10.5.6

Postby zerock » Sat Dec 20, 2008 11:45 pm

odd i don't think. I have had any issues.. hmm.
User avatar
zerock
Crema
 
Posts: 281
Joined: Thu Dec 02, 2004 3:13 pm
Location: Puerto Rico

Re: Adium, Facebook and 10.5.6

Postby timotab » Tue Dec 23, 2008 6:01 pm

timotab wrote:


After reading that link, I followed one person's suggestion, and reinstalled Safari. That fixed it.



and today it broke again. Seems like apple needs to fix Safari.
timotab
Harmless
 
Posts: 6
Joined: Mon Nov 26, 2007 11:32 pm

Re: Adium, Facebook and 10.5.6

Postby dr_flambe » Wed Dec 24, 2008 12:17 pm

Long time user, first post. I did do a search and this seems the most appropriate place for this comment.

I've been running into issues with certain websites and adium running the facebook plugin - this thread has some similarities. I've been tracing it down to the activity and open sessions on my router. Adium's facebook plugin seems to be contributing to the problem - One thing that surprises me is the number of open TCP sessions on my router when the facebook service is activated in adium. Literally hundreds and hundreds. Can any confirm this?

Thank you!
dr_flambe
Harmless
 
Posts: 1
Joined: Wed Dec 24, 2008 12:12 pm

Re: Adium, Facebook and 10.5.6

Postby zerock » Sun Dec 28, 2008 7:39 pm

ok this is an odd problem, and it's happening now to me too.
User avatar
zerock
Crema
 
Posts: 281
Joined: Thu Dec 02, 2004 3:13 pm
Location: Puerto Rico

Re: Adium, Facebook and 10.5.6

Postby evands » Tue Dec 30, 2008 3:18 pm

As noted at http://trac.adiumx.com/wiki/FacebookChat, you can't be reliably logged into Adium and web-Facebook via Safari at the same time.

There is no interaction between logging into Google Talk via Adium and being logged into your Gmail web-based mail. Any seeming interaction is coincidence.

There's no difference in behavior between 10.5.5 and 10.5.6 in either regard. I can't think of any reason that reinstalling Safari would change either situation.
The duck still burns.
--
My company: Saltatory Software. Check it out :)
User avatar
evands
Cocoaforge Admin
 
Posts: 3152
Joined: Thu Dec 02, 2004 5:55 pm
Location: Decatur, GA

Re: Adium, Facebook and 10.5.6

Postby jdandrea » Tue Dec 30, 2008 3:24 pm

evands wrote:As noted at http://trac.adiumx.com/wiki/FacebookChat, you can't be reliably logged into Adium and web-Facebook via Safari at the same time.

It didn't used to be that way though. Only after 10.5.6 did the problems start occurring - with Adium/Facebook and Adium/Gmail. The workaround referenced at the above link (logout of Facebook's chat) does indeed resolve things nicely. Besides, chatting from both interfaces at once can be rather awkward. :)

evands wrote:There is no interaction between logging into Google Talk via Adium and being logged into your Gmail web-based mail. Any seeming interaction is coincidence.

I tend to agree. I don't think the issue lies with Adium at all, but rather with the WebCore framework (wherein lies cookie management). I wonder if there is some overlap there, and Adium is really just an innocent bystander, playing by the book??

evands wrote:There's no difference in behavior between 10.5.5 and 10.5.6 in either regard. I can't think of any reason that reinstalling Safari would change either situation.

Clearing Facebook or Gmail cookies helps mitigate, but only temporarily. :(

In the case of Facebook, it's easy - just disconnect from chat within the Facebook UI. In the case of Gmail, it is more frustrating. Even when disconnected from chat, there are issues. The only fix seems to be the occasional clearing of mail.google.com cookies.

I'm still suspecting WebCore at this point. I say Adium isn't involved at all. (A case of guilt by association, but "it's innocent, I tell you!")
jdandrea
Harmless
 
Posts: 3
Joined: Sat Dec 20, 2008 1:00 pm

Re: Adium, Facebook and 10.5.6

Postby Bundok » Mon Jan 12, 2009 9:29 am

I also began having this problem, but not immediately after upgrading to 10.5.6. It only began about a week ago. What seems to be somewhat different in my case though is that Adium will always stay logged in to Facebook chat. If I then navigate to Facebook inside Safari I have to log in. I can perform a few functions, but then seemingly randomly I'll be required to log in again. The whole time my Adium Facebook account remains online.
Bundok
Harmless
 
Posts: 7
Joined: Mon Dec 03, 2007 4:20 pm

Re: Adium, Facebook and 10.5.6

Postby aitala » Mon Jan 12, 2009 4:17 pm

aitala
Harmless
 
Posts: 2
Joined: Mon Jan 12, 2009 3:18 pm


Return to Adium

Who is online

Users browsing this forum: Exabot [Bot], Google [Bot], Yahoo [Bot]