Jabber connection problems on new MBP

An instant messenger which can connect to AIM, GTalk, Jabber, ICQ, and more.
leedm777
Harmless
Posts: 4
Joined: Thu Jun 09, 2011 1:01 pm

Jabber connection problems on new MBP

Postby leedm777 » Tue Dec 17, 2013 7:20 pm

I'm having trouble getting Jabber/XMPP to work on my new MBP (Retina, 13-inch, Late 2013; OS X 10.9.1). There are two other guys in the office with similar MBP models; one has this issue, the other has no problems. I have an older MBP (2010 15 inch; OS X 10.9.1) on which Adium works fine. And the other clients I've tried work fine, too.

Jabber appears to connect, but it never loads the contact list from the server. Then after a few seconds it displays "Error: XML not well formed" and disconnects. If I leave it sitting there, a connection attempt will eventually work (after an hour or two). But some time later, the connection fails again and I'm offline again.

Here's what looks to be the relevant lines from the debug log:

Code: Select all

13:11:48: Getting accountActionMenuItems for <ESPurpleJabberAccount:4814750 6>:dlee@digium.com
13:11:48: (Libpurple: jabber) jabber_actions: have pep: YES
13:12:12: (Libpurple: jabber) Recv (ssl)(111): <stream:error><xml-not-well-formed xmlns='urn:ietf:params:xml:ns:xmpp-streams'/></stream:error></stream:stream>
13:12:12: (Libpurple: connection) Connection error on 0x6080004b23c0 (reason: 0 description: XML Not Well Formed)
13:12:12: Connection Disconnected: gc=4b23c0 (XML Not Well Formed)
13:12:12: <ESPurpleJabberAccount:4814750 6>:dlee@digium.com accountConnectionReportDisconnect: XML Not Well Formed
13:12:12: (Libpurple: cdsa) receive failed (-9806): Connection reset by peer
13:12:12: (Libpurple: account) Disconnecting account dlee@digium.com/dlee-mac (0x60800015e4b0)
13:12:12: (Libpurple: connection) Disconnecting connection 0x6080004b23c0
13:12:12: (Libpurple: connection) Deactivating keepalive.


Any thoughts on how to debug/fix/workaround?

Thanks!
dave
<><

User avatar
Robby
Cocoaforge Admin
Posts: 2548
Joined: Mon May 01, 2006 3:00 am
Contact:

Re: Jabber connection problems on new MBP

Postby Robby » Tue Dec 17, 2013 7:38 pm

Hi dave,
The issue should be fixed in this pre-release build of Adium 1.5.10: http://nightly.adium.im/adium-adium-1.5 ... gr5805.dmg

Please let us know if it resolves the connection issue for you.

leedm777
Harmless
Posts: 4
Joined: Thu Jun 09, 2011 1:01 pm

Re: Jabber connection problems on new MBP

Postby leedm777 » Tue Dec 17, 2013 9:05 pm

Looks like that fixes it. Thanks!

dave
<><


Return to “Adium”

Who is online

Users browsing this forum: Baidu [Spider]