Adium 1.5.10 Mac OSX performance issues highlighting convos.

An instant messenger which can connect to AIM, GTalk, Jabber, ICQ, and more.
vegman
Harmless
Posts: 4
Joined: Wed May 21, 2014 8:25 pm

Adium 1.5.10 Mac OSX performance issues highlighting convos.

Postby vegman » Wed May 21, 2014 8:31 pm

Long time user, first time poster...


With the most recent update to 1.5.10, there is a huge performance hit while moving the mouse over my conversations, i keep about 40 of them open to my co-workers and associated group chats. As the mouse hovers over the names, Adium is taking a long time to highlight the name and then unhighlight it. It makes usage of Adium extremely slow.

Will be looking to see if I can turn this off, unsure if a known issue or not.

User avatar
Robby
Cocoaforge Admin
Posts: 2553
Joined: Mon May 01, 2006 3:00 am
Contact:

Re: Adium 1.5.10 Mac OSX performance issues highlighting con

Postby Robby » Wed May 21, 2014 10:52 pm

Hi and welcome. =-)

You are the first to report this.

By „my conversations“, do you mean the chat tabs?
Could you please try and get a sample? It would help with identifying the underlying problem. https://trac.adium.im/wiki/Sampling has instructions.

vegman
Harmless
Posts: 4
Joined: Wed May 21, 2014 8:25 pm

Re: Adium 1.5.10 Mac OSX performance issues highlighting con

Postby vegman » Thu May 22, 2014 8:01 pm

While playing around with Adium and getting the sample.

As the mouse moves over all the peoples names associated with my conversations. Each and every one is highlighted, so if I go from the top of the list to say the 20th conversation. I can slowly watch each name get highlighted as the UI tried to catch up with my current location.
Sample:
Adium_2014-05-22_103448_1yJY.sample.txt


Attached a screen shot of a sample window
Adium_2014-05-22_103448_1yJY.sample.txt

In the attached screen shot, if I hover the mouse over the first conversation name (Dummy) and move it down the list, making sure the pointer is over the "Name" and not white space, as I got down to the bottom like "30" I can visually see each of the pervious names highlight down the list.

Doug

User avatar
Robby
Cocoaforge Admin
Posts: 2553
Joined: Mon May 01, 2006 3:00 am
Contact:

Re: Adium 1.5.10 Mac OSX performance issues highlighting con

Postby Robby » Fri May 23, 2014 9:59 am

Hi Doug,

I’m afraid the attachments aren’t showing.

millifoo
Harmless
Posts: 6
Joined: Fri May 23, 2014 4:44 pm

Re: Adium 1.5.10 Mac OSX performance issues highlighting con

Postby millifoo » Fri May 23, 2014 4:50 pm

Hi - same problem here.

Video: https://dl.dropboxusercontent.com/u/469 ... m-slow.mov

2013 Macbook Pro, 2.7ghz, 16gb, 512gb SDD, Mavericks 10.9.3, Adium 1.5.10, using the discreet/fast graphics card.

User avatar
Robby
Cocoaforge Admin
Posts: 2553
Joined: Mon May 01, 2006 3:00 am
Contact:

Re: Adium 1.5.10 Mac OSX performance issues highlighting con

Postby Robby » Fri May 23, 2014 4:57 pm

Thanks.

We’re looking for a sample. Would you be able to provide one?

millifoo
Harmless
Posts: 6
Joined: Fri May 23, 2014 4:44 pm

Re: Adium 1.5.10 Mac OSX performance issues highlighting con

Postby millifoo » Fri May 23, 2014 5:03 pm

doing it now...

millifoo
Harmless
Posts: 6
Joined: Fri May 23, 2014 4:44 pm

Re: Adium 1.5.10 Mac OSX performance issues highlighting con

Postby millifoo » Fri May 23, 2014 5:05 pm

https://dl.dropboxusercontent.com/u/469 ... dium.1.txt

p.s. if you could let me know when you've (and/or anyone on your team who needs it) has grabbed the video and sample, I'll remove them from dropbox.

User avatar
mathuaerknedam
Latté
Posts: 63
Joined: Thu Dec 02, 2004 3:04 pm
Location: Champaign, IL

Re: Adium 1.5.10 Mac OSX performance issues highlighting con

Postby mathuaerknedam » Fri May 23, 2014 8:55 pm

Ahhh, it's the groupchat userlist, not tabs or names within the message view itself.
Matthew

User avatar
Robby
Cocoaforge Admin
Posts: 2553
Joined: Mon May 01, 2006 3:00 am
Contact:

Re: Adium 1.5.10 Mac OSX performance issues highlighting con

Postby Robby » Sat May 24, 2014 3:20 am

millifoo’s video shows tabs (on the left).

vegman
Harmless
Posts: 4
Joined: Wed May 21, 2014 8:25 pm

Re: Adium 1.5.10 Mac OSX performance issues highlighting con

Postby vegman » Tue May 27, 2014 8:44 pm

Retrying to attach my sample using the websites feature...

Adium_2014-05-22_103448_1yJY.sample.txt
Sample of Adium.
(1.32 MiB) Downloaded 486 times


BTW, the video from millifoo is the same issue I am seeing as well.

D

misterflibble
Harmless
Posts: 1
Joined: Thu May 29, 2014 1:04 am

Re: Adium 1.5.10 Mac OSX performance issues highlighting con

Postby misterflibble » Thu May 29, 2014 1:10 am

I'm having the exact same problem with mouseover highlight lag in the group chat window. Typing performance is also very slow: if I type randomly on my keyboard as fast as I can for ten seconds it takes nine additional seconds for the text to finish entering into the text field. Finally, scrolling performance is slow as well.

Anecdotally, I have noticed that the lag is only present when the Adium group chat window is situated on my Retina display. If I move the Adium window to an external Dell monitor attached via Thunderbolt connector, the lag is no longer present.

I am using OS X Mavericks 10.9.3.

Downgrading back to Adium 1.5.9 solves all the lag issues for me.

slvrstn
Harmless
Posts: 2
Joined: Mon Jun 16, 2014 4:58 pm

Re: Adium 1.5.10 Mac OSX performance issues highlighting con

Postby slvrstn » Mon Jun 16, 2014 5:09 pm

Is there any activity on this issue?
Were you able to tell anything from the samples provided?
I'm gonna downgrade to 1.5.9, but it would be nice to know that it will eventually get addressed.
I'll happily submit data before I do if that helps.
Interestingly, I run two different instances of Adium at the same time (using the profile manager) and one of them has the issue and the other doesn't, so it's purely a config issue. The one of mine that does have it has twitter and group chats configured, but probably many other differences. My HW does not have a retina display.

millifoo
Harmless
Posts: 6
Joined: Fri May 23, 2014 4:44 pm

Re: Adium 1.5.10 Mac OSX performance issues highlighting con

Postby millifoo » Sun Oct 26, 2014 8:06 pm

fyi... nuking the Adium 2.0 directory in Application Support (and then painfully reinstalling all my theme, sounds, even actions, etc) "fixed" the problem.

vegman
Harmless
Posts: 4
Joined: Wed May 21, 2014 8:25 pm

Re: Adium 1.5.10 Mac OSX performance issues highlighting con

Postby vegman » Thu Dec 18, 2014 6:37 pm

Ping, any updates here?
Nuking and recreating all my conversations would really suck.

slvrstn
Harmless
Posts: 2
Joined: Mon Jun 16, 2014 4:58 pm

Re: Adium 1.5.10 Mac OSX performance issues highlighting con

Postby slvrstn » Sat Aug 08, 2015 4:39 am

Still hoping there is a fix for this, or at least a way to narrow down what has to be cleaned up.
I'm still running 1.5.9 for the instance that has this issue.
I downloaded the nightly today (1.5.11b2 8/7/15) and it still has the same issue.
Is there something I can do with that to help debug this issue?
Thanks!

millifoo
Harmless
Posts: 6
Joined: Fri May 23, 2014 4:44 pm

Re: Adium 1.5.10 Mac OSX performance issues highlighting con

Postby millifoo » Mon Aug 24, 2015 5:31 pm

I'm still seeing this... a year later :-).

I'd be willing to put a bug bounty on this. $100 donated to Adium via paypal when fixed & I can verify (either in a nightly or beta).

Here are two videos again:

No lag on 1.5.9:
https://dl.dropboxusercontent.com/u/469 ... -1.5.9.mov

And the lag on 1.5.10
https://dl.dropboxusercontent.com/u/469 ... 1.5.10.mov

This is on a zippy-fast late 2013 Retina Macbook that's maxed out, 500gb SSD, 16gb.

BTW, I've tried the nightlies, beta, and 1.7 alphas: all show the same problem. Well, except 1.7, which immediately crashes.


Return to “Adium”

Who is online

Users browsing this forum: Baidu [Spider]