Adium not launching after Yosemite upgrade

An instant messenger which can connect to AIM, GTalk, Jabber, ICQ, and more.
tenbit
Harmless
Posts: 2
Joined: Fri Oct 17, 2014 5:09 am

Adium not launching after Yosemite upgrade

Postby tenbit » Fri Oct 17, 2014 5:15 am

I upgraded my Macbook to Yosemite (OS X 10.10) and now Adium doesn't launch.Every time I click on the icon to launch, it freezes with the spinning beachball. In addition, I lose all my network connections and I am not able to surf the internet even after I kill the app through "Force Quit". I have to restart the computer to get my internet connection back.

I am running OS X 10.10 (14a389) and Adium 1.5.10

Help....

jachin
Harmless
Posts: 1
Joined: Fri Oct 17, 2014 7:37 am

Re: Adium not launching after Yosemite upgrade

Postby jachin » Fri Oct 17, 2014 7:43 am

Yeah, same issue here.

I was able to fix the problem by disabling Bonjour.

I couldn't actually get Adium to launch so I edited the preferences by hand. I found the following file and removed the section for Bonjour.

Code: Select all

~/Library/Application\ Support/Adium\ 2.0/Users/Default/Accounts.plist


This might be a bad way to do things, but it got my Adium back (minus Bonjour). Maybe someone who knows more about Adium's internals can confirm or deny this is a good work around.

tenbit
Harmless
Posts: 2
Joined: Fri Oct 17, 2014 5:09 am

Re: Adium not launching after Yosemite upgrade

Postby tenbit » Fri Oct 17, 2014 2:10 pm

You are awesome... It does work for me too. Thank you so much.

netofrombrazil
Harmless
Posts: 19
Joined: Wed Mar 19, 2014 3:45 am

Re: Adium not launching after Yosemite upgrade

Postby netofrombrazil » Fri Oct 17, 2014 3:21 pm

Hi All,

This is neto from Brazil

How are you?

Unfortunately, that did not work for me.

Any ideas when we are going to have a build that supports Yosemite (10.10)?

Thanks

neto

LawnDarter
Harmless
Posts: 1
Joined: Fri Oct 17, 2014 6:39 pm

Re: Adium not launching after Yosemite upgrade

Postby LawnDarter » Fri Oct 17, 2014 6:43 pm

Thanks jachin. I had the same problem and your resolution worked.

For those investigating, after launching Adium, the discoveryd service would start using 100% CPU. Quitting Adium had no effect. I restated to fix the problem, but I imagine restarting the discoveryd service would have worked too.

ottawan
Harmless
Posts: 1
Joined: Sat Oct 18, 2014 7:38 pm

Re: Adium not launching after Yosemite upgrade

Postby ottawan » Sat Oct 18, 2014 8:49 pm

Thank you! Yosemite + Adium 1.5.10 gave me the same issue (Adium would hang, and even if I force quit it would eliminate all internet connectivity from my computer).

I applied the solution here (remove bonjour from the plist file) and it worked.

ajslater
Harmless
Posts: 1
Joined: Sat Oct 18, 2014 9:19 pm

Re: Adium not launching after Yosemite upgrade

Postby ajslater » Sat Oct 18, 2014 9:22 pm

Thanks folks. This thread helped me fix this on my machine.
Editing the plist file didn't seem to work for me, or I messed up the format. So I found a way to launch Adium.
Stop discoveryd. Start Adium. Disable Bonjour account. Start discoveryd.

Blog with more detail here:
https://aj.slater.net/log/2014/10/16/dn ... e-upgrade/

User avatar
Robby
Cocoaforge Admin
Posts: 2588
Joined: Mon May 01, 2006 3:00 am
Contact:

Re: Adium not launching after Yosemite upgrade

Postby Robby » Sun Oct 26, 2014 12:40 pm

The issue is being tracked here: https://trac.adium.im/ticket/16827.

mbentley
Harmless
Posts: 1
Joined: Tue Oct 28, 2014 3:38 pm

Re: Adium not launching after Yosemite upgrade

Postby mbentley » Tue Oct 28, 2014 3:42 pm

It looks like I am having the same issues with Google Talk accounts on Yosemite and Adium 1.5.10. I was able to disable the accounts and then launch Adium and it worked just fine. It seems that whenever I enable a GTalk account is when I get the beach ball effect and Adium locks up. Interesting enough, I was just using Adium yesterday and it seemed to work just fine for my GTalk accounts. I'm not quite sure what might have changed between then and now.


Return to “Adium”

Who is online

Users browsing this forum: Bing [Bot]