OS X 10.7: Perian doesn't load subtitles in Quicktime X

The Perian forums have moved to Google Groups, this forum is read only.
jjj
Harmless
Posts: 1
Joined: Thu Jul 21, 2011 9:05 pm

OS X 10.7: Perian doesn't load subtitles in Quicktime X

Postby jjj » Thu Jul 21, 2011 9:11 pm

Hi,

I just updated to OS X 10.7 Lion and now I cannot use Quicktime X (10.1) with subtitles. The message pops up that I have to use Quicktime 7 which seems to work fine with Perian showing subtitles. When deactivating "Load External Subtitles" in the Perian settings, I can use Quicktime X without a problem.

Is there anything I'm doing wrong? Any suggestions how I can fix it and use QT X again with subtitles (as it worked perfectly fine under OS X 10.5 and 10.6)?

Thanks!

HeadsNo2
Harmless
Posts: 1
Joined: Fri Jul 22, 2011 7:01 am

Re: OS X 10.7: Perian doesn't load subtitles in Quicktime X

Postby HeadsNo2 » Fri Jul 22, 2011 7:03 am

I noticed the same thing happened when I upgraded to Lion, all of a sudden none of my subtitles loaded for Quicktime X and it asked me to "downgrade" to Quicktime 7. I hope this issue can be resolved, thank you to everyone at Perian for doing such hard work!

Mr VacBob
Crema
Posts: 330
Joined: Thu Jan 04, 2007 11:14 pm
Contact:

Re: OS X 10.7: Perian doesn't load subtitles in Quicktime X

Postby Mr VacBob » Sun Jul 24, 2011 2:23 am

It can't be resolved.

ilmaio
Harmless
Posts: 3
Joined: Sun Jul 24, 2011 7:42 am

Re: OS X 10.7: Perian doesn't load subtitles in Quicktime X

Postby ilmaio » Sun Jul 24, 2011 7:47 am

I have the same problem, after upgrading to lion if i try to open an .avi files with .srt subtitles a message pops up saying to open the file in quicktime7.
If i disable the "load external subtitles" in Perian the error message disappear and i can open the file in quicktime X.

MrVacBob why you say that it can't be resolved?

jekbau
Harmless
Posts: 2
Joined: Sun Jul 24, 2011 9:22 am

Re: OS X 10.7: Perian doesn't load subtitles in Quicktime X

Postby jekbau » Sun Jul 24, 2011 9:27 am

I can confirm the same issue.
After Lion update, when trying to open an .avi file with .srt, it opens in Quicktime 7.
Same file opens in Quicktime X if I check off the loading subtitles options in Perian preferences pane or if I delete the .srt file.

@Mr VacBob: Do you mean it can't be resolved at all, or maybe an update will fix it?

Thanks in advance for anyone who will be able to help.

ilmaio
Harmless
Posts: 3
Joined: Sun Jul 24, 2011 7:42 am

Re: OS X 10.7: Perian doesn't load subtitles in Quicktime X

Postby ilmaio » Sun Jul 24, 2011 12:27 pm

Update: i updated Perian to version 1.2.3, and now quicktime x will open the avi files, but then it stops, the file won't play at all. This appens with the subtitle enabled and with the subtitles disabled.

vater87
Harmless
Posts: 1
Joined: Sun Jul 24, 2011 1:28 pm

Re: OS X 10.7: Perian doesn't load subtitles in Quicktime X

Postby vater87 » Sun Jul 24, 2011 1:29 pm

I updated Perian still nothing, BUT, when I hit the space bar to preview the avi movie it DOES play it. When I try to open it with quicktime, it does not! what am I doing wrong?

gbooker
Cocoaforge Admin
Posts: 723
Joined: Sat May 06, 2006 2:47 am
Contact:

Re: OS X 10.7: Perian doesn't load subtitles in Quicktime X

Postby gbooker » Sun Jul 24, 2011 1:33 pm

ilmaio wrote:MrVacBob why you say that it can't be resolved?

QuickTime Player X has a regression: It cannot open files with more than one video track. Therefore, movie files with more than one video track (subtitles are a video track) will not open in it.

User avatar
The_Tick
Cocoaforge Admin
Posts: 4642
Joined: Thu Dec 02, 2004 6:06 am
Contact:

Re: OS X 10.7: Perian doesn't load subtitles in Quicktime X

Postby The_Tick » Mon Jul 25, 2011 1:58 am

It'd probably be good if everyone running into this filed a bug at:

http://bugreporter.apple.com

jekbau
Harmless
Posts: 2
Joined: Sun Jul 24, 2011 9:22 am

Re: OS X 10.7: Perian doesn't load subtitles in Quicktime X

Postby jekbau » Mon Jul 25, 2011 6:21 am

It'd probably be good if everyone running into this filed a bug at:

http://bugreporter.apple.com


Is there a ticket/thread already open for the issue? If yes, can someone post the link?

ilmaio
Harmless
Posts: 3
Joined: Sun Jul 24, 2011 7:42 am

Re: OS X 10.7: Perian doesn't load subtitles in Quicktime X

Postby ilmaio » Mon Jul 25, 2011 11:25 am

QuickTime Player X has a regression: It cannot open files with more than one video track. Therefore, movie files with more than one video track (subtitles are a video track) will not open in it.


Until the Lion update it always played avi files with subtitles without any problem at all...

damiankitai
Harmless
Posts: 2
Joined: Mon Jul 25, 2011 5:23 pm

Re: OS X 10.7: Perian doesn't load subtitles in Quicktime X

Postby damiankitai » Mon Jul 25, 2011 5:28 pm

Same problem here.
In adition to that, when I go ahead and open the file in QT7, It shows black only video, as the old frontrow perian bug
Of course it can be solved! It worked on SL. SRT subs are not a video track, therefore, QTX can deal with it.

damiankitai
Harmless
Posts: 2
Joined: Mon Jul 25, 2011 5:23 pm

Re: OS X 10.7: Perian doesn't load subtitles in Quicktime X

Postby damiankitai » Mon Jul 25, 2011 6:05 pm

So, here's the situation:
With subs enabled: QTX does not play the files (any avi or mkv standard divx or xvid files) - QT7 plays black screen with subtitles and sound.
without subs enabled: Both QTX and QT7 work fine. Of course, they don't show subtitles.
Tried: Reinstall Perian, downgrade to 1.2.1, nothing helps.
Started since the lion upgrade. No problem before (10.6.8)
Thank god there is Plex and VLC!

gbooker
Cocoaforge Admin
Posts: 723
Joined: Sat May 06, 2006 2:47 am
Contact:

Re: OS X 10.7: Perian doesn't load subtitles in Quicktime X

Postby gbooker » Mon Jul 25, 2011 7:03 pm

damiankitai wrote:SRT subs are not a video track, therefore, QTX can deal with it.

So, you're going to argue with one of the developers on how this works? Good luck on that one.

Mr VacBob
Crema
Posts: 330
Joined: Thu Jan 04, 2007 11:14 pm
Contact:

Re: OS X 10.7: Perian doesn't load subtitles in Quicktime X

Postby Mr VacBob » Thu Jul 28, 2011 3:32 am

damiankitai wrote:Of course it can be solved! It worked on SL. SRT subs are not a video track, therefore, QTX can deal with it.


The implementation of them in Perian involves one. QTX has other ways to display subtitles (I believe some iTunes movies have them), but their appearance is not as attractive as the existing method and I'm not sure if it would be worthwhile. Not that I've had any time to implement that as it is.

legepe
Harmless
Posts: 1
Joined: Sat Jul 30, 2011 11:22 am

Re: OS X 10.7: Perian doesn't load subtitles in Quicktime X

Postby legepe » Sat Jul 30, 2011 11:36 am

Hello,

You can use QuickTime Player 7 with subtitle.
(download 7.6.6 - the http://support.apple.com/kb/dl923 - version that install the QuickTime Player 7 in the "Utilities" folder).
But any app that use QTX won't work or display subtitles.
Example : I use my iPad to watch movie (Zumocast) stocked on my iMac and the app doesn't display subtitles anymore since the upgrade to Lion, because it use QTX on the iMac side.

BR,
legepe

JamesKeller
Harmless
Posts: 1
Joined: Sat Jul 30, 2011 10:44 pm

Re: OS X 10.7: Perian doesn't load subtitles in Quicktime X

Postby JamesKeller » Sat Jul 30, 2011 10:48 pm

I have been having the same issue since the Perian 1.2.3 update. AVI files (even ones that have no subtitles) will not play... they will open, but not play. I remove perian, and get the same result. Doing a Quick view of the file will play fine... there is nothing wrong with the files... QT7 plays normal... just QTX will not play the files. Ever since it updated from 1.2.2 to 1.2.3 ... where can I and how do I downgrade perian? Is it possible? Is there a solution in the works?

Thanks,
J

nilnil
Harmless
Posts: 2
Joined: Sun Aug 07, 2011 11:22 am

Re: OS X 10.7: Perian doesn't load subtitles in Quicktime X

Postby nilnil » Sun Aug 07, 2011 11:55 am

legepe wrote:You can use QuickTime Player 7 with subtitle.
(download 7.6.6 - the http://support.apple.com/kb/dl923 - version that install the QuickTime Player 7 in the "Utilities" folder).


Even my Quicktime player 7 failed 2 load subtitles when playing avi files like it used to -- but it showed subs for mkv files and the videos were all fine.

My ultimate problem is, after updating, any avi file with subtitles didn't have sound (skipping at the start then complete silence) after being converted by iSubtitle 2.5.2 to iphone video m4v. And since the QT player pro 7 couldn't load subs, I couldn't use that to convert for my iphone watch either. My iphone is complete starving for subtitled videos!!!

And since I upgraded to Lion shortly after updating Perian to 1.2.3, I couldn't tell which one contributed more to the problem. It might be Perian though 'cause it seems iSubtitle use Perian codes too...

Please, let there be an update!!! But I might at first downgrade Perian to 1.2.2 as some users suggested and see how it goes...

nilnil
Harmless
Posts: 2
Joined: Sun Aug 07, 2011 11:22 am

Re: Downgrade to 1.2.2 works, but not for QT X

Postby nilnil » Sun Aug 07, 2011 4:48 pm

I removed 1.2.3 and then installed 1.2.2. Now my Quicktime player 7 pro works perfectly fine, but the QT 10.1 is still the same, asking me to get 7. Anyway I always use VLC and Mplayer, so before Perian solved this problem, I suggest you QT X guys either switch to other players or... be patient and good luck.

donki89
Harmless
Posts: 1
Joined: Wed Aug 10, 2011 1:34 pm

Re: OS X 10.7: Perian doesn't load subtitles in Quicktime X

Postby donki89 » Wed Aug 10, 2011 1:43 pm

Can anyone explain then why avi files with subtitles does work in Quickview with OS X Lion and not with Quicktime X? Why is it apparently not possible with QTX but does it work without any hesitations when I try it with Quickview by pushing the spacebar in Finder?


Return to “Perian”

Who is online

Users browsing this forum: Google [Bot]