AVI Audio Problem

The Perian forums have moved to Google Groups, this forum is read only.
kennethhsu
Harmless
Posts: 5
Joined: Sun Feb 12, 2012 7:34 am

AVI Audio Problem

Postby kennethhsu » Sun Feb 12, 2012 7:47 am

Hi Perian Community,

I currently had reinstalled my OS Lion (10.7.3) with Perian because I was having some issues and I hoped this would help but it didn't.
I searched for help in the forum however removing components in quicktime did not help. (I actually couldn't find those two components)
I am having problems with "some" (not all) of the AVI files with that audio will only play for a few seconds, and skipping it will resolve it for a few seconds. The odd thing is I am only experience this on some certain files. And I am absolutely positive that these files aren't broken in anyway because they work well in VLC and DIVX player. Can someone please help me out a little here? Any opinion or suggestions would be appreciated!

Thanks!

Edited: I notices that it happens a lot more frequently with larger files (like clips more than an hour long), hopefully that helps.

gbooker
Cocoaforge Admin
Posts: 723
Joined: Sat May 06, 2006 2:47 am
Contact:

Re: AVI Audio Problem

Postby gbooker » Sun Feb 12, 2012 3:03 pm

kennethhsu wrote:I searched for help in the forum however removing components in quicktime did not help. (I actually couldn't find those two components)

There are far more than just two buggy components. The DivX components are particularly bad. See http://www.perian.org/#support

kennethhsu wrote:I am having problems with "some" (not all) of the AVI files

We need a sample of such a file.

kennethhsu
Harmless
Posts: 5
Joined: Sun Feb 12, 2012 7:34 am

Re: AVI Audio Problem

Postby kennethhsu » Sun Feb 12, 2012 9:03 pm

Yes I had looked that up too. However, I could not locate any of those files, except:
DivX Decoder.component

Is this normal?
How can I provide such file? How do I split it without editing it? I know how to split it in programs like Final Cut, but will that ruin it? Because is that kind of like reformatting the file? I can upload the whole thing if you want; however, it is 1.41GB

Edited: I tried to split the video and it seems to work with shorter clips, so I am guessing there's problems with longer (larger) files?
I tested 3 movies and they are all larger at 1.2GB, all have the same problem, audio only works for a second or two, and it works under all other programs like VLC.

*Currently uploading one of it to dropbox, I will post a public link here*
http://db.tt/47iWUXFC *This link will expire on February 19, 2012

gbooker
Cocoaforge Admin
Posts: 723
Joined: Sat May 06, 2006 2:47 am
Contact:

Re: AVI Audio Problem

Postby gbooker » Sun Feb 12, 2012 11:17 pm

DivX Decoder needs to go, PERIOD! We've tracked down several bugs to this POS, one of which is exactly what you are describing. Remove it and restart your QuickTime Player.

I'm downloading your file to see if I can determine more.

kennethhsu
Harmless
Posts: 5
Joined: Sun Feb 12, 2012 7:34 am

Re: AVI Audio Problem

Postby kennethhsu » Sun Feb 12, 2012 11:19 pm

Yes, I already removed it and restarted QuickTime X, still experiencing the problem though.

gbooker
Cocoaforge Admin
Posts: 723
Joined: Sat May 06, 2006 2:47 am
Contact:

Re: AVI Audio Problem

Postby gbooker » Mon Feb 13, 2012 1:30 am

Congratulations, you downloaded another file which perfectly exemplifies the fact that avi is a format that needs to die! It's badly packetized by some moron who doesn't seem to understand that what constitutes an audio frame nor how to correctly calculate timecodes. Remux the file, and it's fine.

kennethhsu
Harmless
Posts: 5
Joined: Sun Feb 12, 2012 7:34 am

Re: AVI Audio Problem

Postby kennethhsu » Mon Feb 13, 2012 1:32 am

I am a little lost lol... so remux the file? What does that mean?

gbooker
Cocoaforge Admin
Posts: 723
Joined: Sat May 06, 2006 2:47 am
Contact:

Re: AVI Audio Problem

Postby gbooker » Mon Feb 13, 2012 3:59 am

It means rip the audio/video streams out and make a new file with the streams copied. AviDemux can do this, so does a lot of others. You have a really really broken file there.

Alternatively, you can buy the movie and handbrake it into a real format (m4v) achieving higher quality in a smaller file size.

kennethhsu
Harmless
Posts: 5
Joined: Sun Feb 12, 2012 7:34 am

Re: AVI Audio Problem

Postby kennethhsu » Mon Feb 13, 2012 4:09 am

Ok I understand now, can you verify the program "remux"?
http://www.macupdate.com/app/mac/35968/remux

See if that does it? This will be my question, but your help is much appreciated!

gbooker
Cocoaforge Admin
Posts: 723
Joined: Sat May 06, 2006 2:47 am
Contact:

Re: AVI Audio Problem

Postby gbooker » Mon Feb 13, 2012 2:04 pm

I've never used that tool, but its description seems to be what you desire. When I said remux, I was referring to a generic process, not a specific program.


Return to “Perian”

Who is online

Users browsing this forum: Yahoo [Bot]