Could Use Help

An iPhone client for Growl available on the App Store.
bradynapier
Harmless
Posts: 3
Joined: Fri Aug 23, 2013 8:38 pm

Could Use Help

Postby bradynapier » Fri Aug 23, 2013 9:04 pm

I am trying to have my automation controller use this API to send notifications - however I am running into a bit of a snag as I am getting the following returned when i send a command:

HTTP/1.0\x20400\x20Bad\x20request\x0D\x0ACache-Control:\x20no-cache\x0D\x0AConnection:\x20close\x0D\x0AContent-Type:\x20text/html\x0D\x0A\x0D\x0A<html><body><h1>400\x20Bad\x20request</h1>\x0AYour\x20browser\x20sent\x20an\x20invalid\x20request.\x0A</body></html>\x0A

I am sure I am just sending the wrong header information, etc I am a total noob with this stuff - that is why more examples would be nice on your site!

All I can really do is send a string to a IP Address (my controller doesn't support DNS so I found the IP of the API): 67.215.65.132 (hoping this is static)

Then I just sent this:
apikey=45c2d7384bf87e4a3eede05f41a98835d46ae9e2&application=TotalControl&event=Locks

Any assistance is greatly appreciated!

I tried sending this as well:
POST\x20/publicapi/add?apikey=ef3526c57ba0c7e10800079930ba9ba24adbf029&application=Total\x20Control&event=Locks&description=Hello\x20HTTP/1.1

Same Response as above
Last edited by bradynapier on Fri Aug 23, 2013 9:29 pm, edited 1 time in total.

bradynapier
Harmless
Posts: 3
Joined: Fri Aug 23, 2013 8:38 pm

Re: Could Use Help

Postby bradynapier » Fri Aug 23, 2013 9:14 pm

I've noticed that even just using the REST plugin for chrome doesn't work when i send the data!

TYPE: POST

apikey=45c2d7384bf87e4a3eede05f41a98835d46ae9e2&application=TotalControl&event=Locks&description=hello

I get the following response :
<?xml version="1.0" encoding="UTF-8"?>
<prowl>
<error code="401">API key is required</error>
</prowl>


Return to “Prowl”

Who is online

Users browsing this forum: Exabot [Bot]