Page 1 of 1

GrowlMail Won't Install

Posted: Tue Oct 20, 2009 7:37 pm
by airic82
We're having trouble getting GrowlMail to install on Snow Leopard, and I think it's a permission problem. We recently had an issue of some permissions getting screwed up and we thought we had them all fixed until this popped up today. When we try to install GrowlMail, the installer says "Installer is Damaged" then talks about file permissions.

Can someone tell me where to check the permissions and make sure they're correct?

Thanks,
Eric

Re: GrowlMail Won't Install

Posted: Thu Oct 29, 2009 11:51 pm
by Beatleboy
I installed GrowlMail in Leopard and since upgraded to Snow Leopard. This didn't happen at first, but eventually I started getting a message saying that Mail disabled GrowlMail and I should contact Growl for a version compatible with Mail 4.1. There is none. After all was said and done, it still works. I still get incoming mail notifications on my desktop, so go figure...

Re: GrowlMail Won't Install

Posted: Fri Oct 30, 2009 4:29 am
by boredzo
Beatleboy wrote:… I should contact Growl for a version compatible with Mail 4.1. There is none.


Yes there is.

Re: GrowlMail Won't Install

Posted: Fri Oct 30, 2009 11:22 am
by Beatleboy
Can you post the link please? I searched their website without success. All I can find is the download of Growl 2.1 and in that bundle is the GrowlMail app which is the same one that I have already.

Re: GrowlMail Won't Install

Posted: Fri Oct 30, 2009 11:50 am
by boredzo
Beatleboy wrote:Can you post the link please?


http://growl.info/

… All I can find is the download of Growl 2.1 …


There is no such version. I assume you mean 1.2, which is the latest version.

… and in that bundle is the GrowlMail app which is the same one that I have already.


GrowlMail is not an application, and GrowlMail 1.2 is compatible with Mac OS X 10.6.1 (including Mail 4.1).

Re: GrowlMail Won't Install

Posted: Sun Nov 01, 2009 3:41 pm
by Beatleboy
OK, so I uninstalled the Growl 1.2 that I presently have and reinstalled the re-downloaded version of Growl 1.2. I still get this error message from Mail 4.1:

Incompatible Plug-ins Disabled
Mail has disabled the following plug-ins:
GrowlMail
Contact the makers of these plug-ins for versions that are compatible with Mail 4.1 and Message 4.1

Nothing changed. Are you sure Snow Leopard isn't the culprit? It was working fine with the same versions in Leopard.

As I mentioned before, after I click "OK", Growl works fine with Mail as if nothing was diabled. I just keep getting this error message when I open Mail and I don't know what to do to get rid of it. It's frustrating.

Re: GrowlMail Won't Install

Posted: Sun Nov 01, 2009 7:31 pm
by boredzo
Beatleboy wrote:I still get this error message from Mail 4.1:

Incompatible Plug-ins Disabled
Mail has disabled the following plug-ins:
GrowlMail
Contact the makers of these plug-ins for versions that are compatible with Mail 4.1 and Message 4.1


You probably still (somehow) have an old version of GrowlMail installed. Check both of these locations:

  • Your Home folder
    • Library
      • Mail
        • Bundles
  • Your startup disk
    • Library
      • Mail
        • Bundles

Are you sure Snow Leopard isn't the culprit? … Growl works fine with Mail as if nothing was diabled.


Snow Leopard could very well be to blame in some unknown way, but GrowlMail 1.2 is compatible with version 10.6.1 of it.

Re: GrowlMail Won't Install

Posted: Mon Nov 02, 2009 1:33 am
by Beatleboy
The GrowlMail plists were telling me that it is version 1.0. I deleted the plists in both folders you mentioned and restarted Mail and GrowlMail. This time, Mail just automatically quit and sent Apple an error report. I uninstalled Growl v1.2 and GrowlMail, then re-downloaded it from the website. After reinstalling both Growl v1.2 and GrowlMail, I reopened Mail. This time, it started without giving me the error message. Now it's a matter of time before I receive email to see if I get a notification bubble. Thank you so much for your help. :-)

Re: GrowlMail Won't Install

Posted: Mon Nov 02, 2009 4:52 am
by boredzo
Beatleboy wrote:The GrowlMail plists were telling me that it is version 1.0. I deleted the plists in both folders …


Why would you only delete the plists? If its Info.plist was out of date, the entire GrowlMail was probably out of date. Also, having two copies of GrowlMail (or of Growl) installed is always a problem.

I uninstalled Growl v1.2 …


There's no reason to do that, since Growl was working fine.

I apologize for misreading one of your earlier messages—I thought you had already uninstalled GrowlMail, which would have solved the problem, but you only uninstalled Growl, which was unrelated. Uninstalling GrowlMail this time is what solved it.

Re: GrowlMail Won't Install

Posted: Mon Nov 02, 2009 5:26 am
by Beatleboy
Yes, it is solved now, but I have no idea why my system installed it in both the boot drive as well as my Home folder. That is a mystery. I trashed the plist files thinking that restarting it would replace them with "refreshed" plists. That's all. Seeing as I had to download the whole Growl package anyway, I figured I would just start from scratch and reinstall everything. That's the only reason I uninstalled Growl itself.

Re: GrowlMail Won't Install

Posted: Mon Nov 02, 2009 5:31 am
by boredzo
Beatleboy wrote:I trashed the plist files thinking that restarting it would replace them with "refreshed" plists.


That's only true of Growl ticket files, not Info.plist files. An Info.plist file is not simply a preference file that something writes out—it is a vital part of whatever bundle it's in. It's part of the bundle's skeleton. If you delete it, you have broken that bundle.

Re: GrowlMail Won't Install

Posted: Mon Nov 02, 2009 11:26 am
by Beatleboy
OK. Now I understand. It's all or nothing. It's just as well that I uninstalled the whole bundle. As I said, everything is working perfectly now.