Growl-WithInstaller 10.4 through 10.6, how?

The Growl forums have moved to Google Groups, this forum is read only.
alexcurylo
Harmless
Posts: 2
Joined: Thu Oct 22, 2009 2:20 am

Growl-WithInstaller 10.4 through 10.6, how?

Postby alexcurylo » Thu Oct 22, 2009 2:32 am

So I've got this Growl-using program that needs to support 10.4 through 10.6 users. Is it possible to embed both the 1.1.6 and 1.2 versions of Growl-WithInstaller in an application to make installation and invocation transparent to the user? Or what's the recommended practice for dealing with that situation?

Unfortunately, separate downloads for 10.4 and not-10.4 is not an acceptable solution, since the target audience for this product overwhelmingly has absolutely no idea what version of the OS they might be running. Indeed, it is beyond the capabilities of a depressingly large number of them to figure out on their own without spending half an hour with tech support that they need to download the Mac installer and not the Windows installer...

User avatar
boredzo
Cocoaforge Admin
Posts: 796
Joined: Mon Dec 06, 2004 7:49 am
Contact:

Re: Growl-WithInstaller 10.4 through 10.6, how?

Postby boredzo » Thu Oct 22, 2009 4:38 am

alexcurylo wrote:So I've got this Growl-using program that needs to support 10.4 through 10.6 users. … what's the recommended practice for dealing with that situation?


Include Growl-WithInstaller.framework 1.2. If it breaks anything on 10.4.11, send us bug reports.

alexcurylo
Harmless
Posts: 2
Joined: Thu Oct 22, 2009 2:20 am

Re: Growl-WithInstaller 10.4 through 10.6, how?

Postby alexcurylo » Thu Oct 22, 2009 5:45 am

boredzo wrote:
alexcurylo wrote:So I've got this Growl-using program that needs to support 10.4 through 10.6 users. … what's the recommended practice for dealing with that situation?


Include Growl-WithInstaller.framework 1.2. If it breaks anything on 10.4.11, send us bug reports.


Oh, that will work? I just assumed from "If you require Growl for Mac OS X 10.4.11, please download Growl 1.1.6." on the front page that Bad Things Would Happen if a 1.2 SDK's framework-linked application ran on 10.4. Ne-ver mind then...

User avatar
boredzo
Cocoaforge Admin
Posts: 796
Joined: Mon Dec 06, 2004 7:49 am
Contact:

Re: Growl-WithInstaller 10.4 through 10.6, how?

Postby boredzo » Thu Oct 22, 2009 6:24 am

alexcurylo wrote:I just assumed from "If you require Growl for Mac OS X 10.4.11, please download Growl 1.1.6." on the front page that Bad Things Would Happen if a 1.2 SDK's framework-linked application ran on 10.4.


No. Growl 1.2 requires Mac OS X 10.5 or later (preferably 10.5.8 or later), but the frameworks require 10.4 or later (preferably 10.4.11 or later).

That does raise one failure point: Growl-WithInstaller.framework 1.2 will prompt users to install Growl even if running 10.4.x. Our installation prompt does contain an OS-version check, but we haven't updated it. Sorry about that; I'll go file that bug now.

luciocosmo
Harmless
Posts: 5
Joined: Wed Oct 07, 2009 7:19 am

Re: Growl-WithInstaller 10.4 through 10.6, how?

Postby luciocosmo » Fri Oct 23, 2009 10:09 am

I got a crash with "Growl-WithInstaller.framework 1.2" on a 10.4

dyld: Library not loaded: @executable_path/../Frameworks/Growl-WithInstaller.framework/Versions/A/Growl-WithInstaller
Referenced from: /Volumes/lucio/Projects/code4/Tilimi/C/Build/Tilimi.app/Contents/MacOS/Tilimi
Reason: no suitable image found. Did find:
/Volumes/lucio/Projects/code4/Tilimi/C/Build/Tilimi.app/Contents/MacOS/../Frameworks/Growl-WithInstaller.framework/Versions/A/Growl-WithInstaller: unknown required load command 0x8000001F
/Volumes/lucio/Projects/code4/Tilimi/C/Build/Tilimi.app/Contents/MacOS/../Frameworks/Growl-WithInstaller.framework/Versions/A/Growl-WithInstaller: unknown required load command 0x8000001F

The growl installed is 1.1.4, so this happens to our beta users. I would like no crash and no growl usage, or at least an alert.
What to do ? Can we link with a framework 1.1.4 compatible ? Where to download it ?

Thanks

User avatar
boredzo
Cocoaforge Admin
Posts: 796
Joined: Mon Dec 06, 2004 7:49 am
Contact:

Re: Growl-WithInstaller 10.4 through 10.6, how?

Postby boredzo » Fri Oct 23, 2009 10:21 am

luciocosmo wrote:I got a crash with "Growl-WithInstaller.framework 1.2" on a 10.4

dyld: Library not loaded: @executable_path/../Frameworks/Growl-WithInstaller.framework/Versions/A/Growl-WithInstaller
Referenced from: /Volumes/lucio/Projects/code4/Tilimi/C/Build/Tilimi.app/Contents/MacOS/Tilimi
Reason: no suitable image found. Did find:
/Volumes/lucio/Projects/code4/Tilimi/C/Build/Tilimi.app/Contents/MacOS/../Frameworks/Growl-WithInstaller.framework/Versions/A/Growl-WithInstaller: unknown required load command 0x8000001F
/Volumes/lucio/Projects/code4/Tilimi/C/Build/Tilimi.app/Contents/MacOS/../Frameworks/Growl-WithInstaller.framework/Versions/A/Growl-WithInstaller: unknown required load command 0x8000001F


Curious. What version of Mac OS X was this running on?

The growl installed is 1.1.4 …


That's not relevant.

Can we link with a framework 1.1.4 compatible ?


Yes. Version 1.2 of the framework is compatible with all 1.1 versions of Growl.

luciocosmo
Harmless
Posts: 5
Joined: Wed Oct 07, 2009 7:19 am

Re: Growl-WithInstaller 10.4 through 10.6, how?

Postby luciocosmo » Fri Oct 23, 2009 12:15 pm

I'm using latest SDK DMG which i hope be the latest.
The problem occours on two machines both with 10.4, and on machines of our users which I cannot investigate.

Mac OSX is 10.4.11

The problem occours at startup time, so I have not other solutions than removing the framework, right ?
Am I doing something wrong with project settings ?

Thanks.

User avatar
boredzo
Cocoaforge Admin
Posts: 796
Joined: Mon Dec 06, 2004 7:49 am
Contact:

Re: Growl-WithInstaller 10.4 through 10.6, how?

Postby boredzo » Fri Oct 23, 2009 11:47 pm

luciocosmo wrote:The problem occours on two machines both with 10.4, and on machines of our users which I cannot investigate.

Mac OSX is 10.4.11

The problem occours at startup time, … Am I doing something wrong with project settings ?


It doesn't sound like it.

Can you try the non-installer framework and let us know whether that works?

luciocosmo
Harmless
Posts: 5
Joined: Wed Oct 07, 2009 7:19 am

Re: Growl-WithInstaller 10.4 through 10.6, how?

Postby luciocosmo » Tue Nov 03, 2009 4:00 pm

The same for the "with installer" or "without installer" framwork.
Can I download somewhere a previous version of the framework ? I don't use any advanced feature.

Thanks


Return to “Growl”

Who is online

Users browsing this forum: No registered users