Login Process Repeating Indefinitely?

The Cyberduck forums have moved to Google Groups, this forum is read only.
rsigg
Harmless
Posts: 3
Joined: Thu Apr 30, 2009 5:45 pm

Login Process Repeating Indefinitely?

Postby rsigg » Thu Apr 30, 2009 5:55 pm

I have already gone over this problem with my hosting provider and their support is unable to replicate my problem, so I'm turning to the forum here.
The problem is this: every time I try to login to one particular server, it logs in over and over again. It was fine connecting for weeks until recently.

What I mean is this: it goes through the process of logging in (successfully, it says), authenticating, listing the directory, and then it starts all over again and does not stop, it just repeats the login process over and over again unless I stop the process. It never opens the directory.

None of my other connections are experiencing this problem. Also, I am able to use other FTP clients to connect successfully (e.g. Fetch, ugh).

The connection is setup correctly and my hosting provider has been able to connect successfully with Cyberduck.
I've re-installed Cyberduck as well.

I know this is pretty vague but my questions are:
1. Has anyone else had this problem before? If so, any way out?
2. Are there any preferences files which might be sticking around post-uninstall that I might be able to delete in order to start REALLY fresh?

dkocher
Cyberduck Team
Posts: 763
Joined: Thu Feb 03, 2005 1:41 pm
Location: Switzerland
Contact:

Re: Login Process Repeating Indefinitely?

Postby dkocher » Thu Apr 30, 2009 7:43 pm

That sounds very much like http://trac.cyberduck.ch/ticket/3137 which is an incompatibility with bogus

Code: Select all

MLSD
directory listings. You should be able to connect fine using the 3.1.2 release however.

rsigg
Harmless
Posts: 3
Joined: Thu Apr 30, 2009 5:45 pm

Re: Login Process Repeating Indefinitely?

Postby rsigg » Thu Apr 30, 2009 8:27 pm

That DOES sound very similar, especially because both threads' problems were associated with MediaTemple as the host:
If no remote path is set, it simply keeps reconnecting over and over and over again.

If the remote path of "/" is set, it connects, disconnects and remains on the bookmarks page. But for some reason there's a green connected indicator next to the bookmark (can't find a browser anywhere though for the connection).

All of that is exactly the same.

I'm using 3.2 right now.
I do remember a recent upgrade but since I was not logging in to this particular server at the time.
Are you recommending that I download an older version and then just test each new version as it comes out?

I only ask since this server is now the main server I need to access.

Thanks for your help!

rsigg
Harmless
Posts: 3
Joined: Thu Apr 30, 2009 5:45 pm

Re: Login Process Repeating Indefinitely?

Postby rsigg » Thu Apr 30, 2009 8:30 pm

OR should I use the workaround described in the other thread:
defaults write ch.sudo.cyberduck ftp.sendMlsdListCommand false


Thanks again for your help.


Return to “Cyberduck”

Who is online

Users browsing this forum: Google [Bot]