Frustration at support for 10.3.9 being dropped in 1.1

An instant messenger which can connect to AIM, GTalk, Jabber, ICQ, and more.
User avatar
Wizardling
Harmless
Posts: 19
Joined: Mon Oct 10, 2005 3:11 pm
Location: Tauranga, New Zealand
Contact:

Frustration at support for 10.3.9 being dropped in 1.1

Postby Wizardling » Mon Aug 13, 2007 8:00 am

I suppose there were good reasons for this (?), but it is frustrating for those of us who prefer to stay one OS version behind. Couldn't this have waited till Leopard was released? Even Apple supports the previous OSX version knowing many people like to play it safe.
If you're not part of the solution, you're part of the precipitate.

Sean
Latté
Posts: 97
Joined: Sun Dec 05, 2004 2:54 am
Location: NJ

Postby Sean » Mon Aug 13, 2007 8:39 am

No offense but the percentage of Adium users still on Panther is probably not even in the double digits... It just doesn't make much sense to keep support for it at this point IMO. It's holding things back and making it more difficult for the developers.

Besides, Leopard is coming out in just two months anyway. Until then you still have Adium 1.0 which is perfectly fine.

Crypt
Cocoaforge Admin
Posts: 491
Joined: Sun May 15, 2005 6:16 pm
Location: Brooklyn, New York
Contact:

Postby Crypt » Mon Aug 13, 2007 9:12 am

Sean wrote:No offense but the percentage of Adium users still on Panther is probably not even in the double digits... It just doesn't make much sense to keep support for it at this point IMO. It's holding things back and making it more difficult for the developers.

Besides, Leopard is coming out in just two months anyway. Until then you still have Adium 1.0 which is perfectly fine.


Indeed. If any of you are interested in the stats of Adium http://sparkle.adiumx.com/
"Bite my shiny metal ass!"
- Bender

adiumx DOT com MOTHA F**KA!

User avatar
Catfish_Man
Cocoaforge Admin
Posts: 1203
Joined: Thu Dec 02, 2004 6:30 am
Location: Portland, Oregon
Contact:

Re: Frustration at support for 10.3.9 being dropped in 1.1

Postby Catfish_Man » Mon Aug 13, 2007 11:45 am

Wizardling wrote:I suppose there were good reasons for this (?), but it is frustrating for those of us who prefer to stay one OS version behind. Couldn't this have waited till Leopard was released? Even Apple supports the previous OSX version knowing many people like to play it safe.


The intention was to wait until Leopard was released, but Apple delayed Leopard.

User avatar
The_Tick
Cocoaforge Admin
Posts: 4642
Joined: Thu Dec 02, 2004 6:06 am
Contact:

Postby The_Tick » Mon Aug 13, 2007 12:06 pm

Also, Adium is developed by people who have very limited time. Supporting 10.3.9 really meant that we had to beg people to test 10.3.9 every time we made a release, due to the fact that none of us have 10.3.9 boxes to test on. Also, it adds more code to the codebase, so that's more work in maintaining the setup, and it was just plain annoying.

For a free application where we have limited everything, a decision was made to drop something that we just didn't need to worry about anymore. 10.3.9 is how old? It would have made the SoC projects last year a lot tougher if we had required students to code towards it.

Dr. Mobius
Harmless
Posts: 15
Joined: Wed Apr 06, 2005 6:32 pm
Location: Evansville, IN
Contact:

Postby Dr. Mobius » Mon Aug 13, 2007 12:06 pm

One more reason why October can't get here fast enough...

*grumble*

User avatar
TheSilverFox06
Grandé
Posts: 770
Joined: Fri Dec 03, 2004 10:16 pm
Location: St. Paul, MN
Contact:

Postby TheSilverFox06 » Tue Aug 14, 2007 8:47 am

Even though there are certainly some significant improvements in 1.1, it's not like there's some super-duper awesome be-all-end-all feature that it has over 1.0.5. I'm sure you can put up with it for 2 more months :)

Dr. Mobius
Harmless
Posts: 15
Joined: Wed Apr 06, 2005 6:32 pm
Location: Evansville, IN
Contact:

Postby Dr. Mobius » Tue Aug 14, 2007 4:30 pm

What's new in 1.0.6? There's nothing about it in the included change log.

User avatar
zac
Cocoaforge Admin
Posts: 1518
Joined: Sun Mar 27, 2005 3:19 pm
Contact:

Postby zac » Tue Aug 14, 2007 4:46 pm

1.0.6 fixes the Sparkle updater so that the minimumSystemVersion flag can be set.

In other words, it'll stop asking 10.3.9 users to upgrade to 1.1.


Return to “Adium”

Who is online

Users browsing this forum: No registered users