UNOFFICIAL Adium with msnp15 testing

An instant messenger which can connect to AIM, GTalk, Jabber, ICQ, and more.
User avatar
Dimmuxx
Crema
Posts: 359
Joined: Mon Apr 21, 2008 1:42 pm
Location: Sweden

Re: UNOFFICIAL Adium with msnp15 testing

Postby Dimmuxx » Thu Aug 14, 2008 10:07 am

hippy dave wrote:yeah i've been getting occasional crashes, which look to be slp-related - eg. the last one:

want the debug logs?


Sure, why not. A slp* crash was fixed today btw so I'll do a new build soon.

Edit: New build is out and let's hope this one built correctly for ppc. Please report if the timestamps work correctly too.

User avatar
Chabou
Harmless
Posts: 16
Joined: Mon Jun 30, 2008 7:58 pm
Location: France
Contact:

Re: UNOFFICIAL Adium with msnp15 testing

Postby Chabou » Thu Aug 14, 2008 6:32 pm

By timestamps you mean this bug I think ?

supertoom2 wrote:In the 24709 build I can't see time stamps in the conversations, it just says HH.mm.


If so, then it's ok now. btw, unlike Adium29 would suggest, the problem was present in all messages styles.
This posting is provided "AS IS" with no warranties, and confers no rights. ;)

User avatar
Dimmuxx
Crema
Posts: 359
Joined: Mon Apr 21, 2008 1:42 pm
Location: Sweden

Re: UNOFFICIAL Adium with msnp15 testing

Postby Dimmuxx » Thu Aug 14, 2008 6:56 pm

Chabou wrote:By timestamps you mean this bug I think ?

supertoom2 wrote:In the 24709 build I can't see time stamps in the conversations, it just says HH.mm.


If so, then it's ok now. btw, unlike Adium29 would suggest, the problem was present in all messages styles.


okay, good to know. :)

supertoom2
Harmless
Posts: 3
Joined: Sun Oct 29, 2006 12:35 pm

Re: UNOFFICIAL Adium with msnp15 testing

Postby supertoom2 » Thu Aug 14, 2008 7:07 pm

For me the timestamp bug is half fixed, half still there. The time in the header of the conversation is displayed correctly, so are the day/year/date in the status field, but for the time for every single message sent, it still says HH.mm.

EDIT: Now it seems to work, i just had to switch on/off displaying seconds in the time format! :D
Last edited by supertoom2 on Thu Aug 14, 2008 7:11 pm, edited 1 time in total.

User avatar
Dimmuxx
Crema
Posts: 359
Joined: Mon Apr 21, 2008 1:42 pm
Location: Sweden

Re: UNOFFICIAL Adium with msnp15 testing

Postby Dimmuxx » Thu Aug 14, 2008 7:10 pm

supertoom2 wrote:For me the timestamp bug is half fixed, half still there. The time in the header of the conversation is displayed correctly, so are the day/year/date in the status field, but for the time for every single message sent, it still says HH.mm.


You have to reset that in advanced -> Messages as the ticket for the bug says. http://trac.adiumx.com/ticket/10630

User avatar
Leeiio
Harmless
Posts: 2
Joined: Sun Aug 10, 2008 1:16 pm
Contact:

Re: UNOFFICIAL Adium with msnp15 testing

Postby Leeiio » Sat Aug 16, 2008 6:05 am

My adium was still crashed,it is the newest vision.

with the report

Code: Select all

Date/Time:       2008-08-16 14:00:55.717 +0800
OS Version:      Mac OS X 10.5.4 (9E17)
Report Version:  6

Exception Type:  EXC_BAD_ACCESS (SIGBUS)
Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000005
Crashed Thread:  0

Thread 0 Crashed:
0   com.apple.CoreFoundation         0x9011f2d4 CFRetain + 36
1   com.apple.CoreFoundation         0x900adf25 CFArrayCreate + 357
2   com.apple.CFNetwork              0x95e748a8 CFHostCreateWithName + 72
3   com.adiumX.AdiumPurple           0x1845e24a -[AdiumPurpleDnsRequest startLookup] + 171
4   com.adiumX.AdiumPurple           0x1845e42d adiumPurpleDnsRequestResolve + 58
5   libpurple                        0x1861a5ac purple_dnsquery_ui_resolve + 69
6   libpurple                        0x1861affd handle_next_queued_request + 92
7   libpurple                        0x1861b3e6 resolve_host + 27
8   com.adiumX.AdiumPurple           0x18439150 callTimerFunc + 120
9   com.apple.CoreFoundation         0x9011db45 CFRunLoopRunSpecific + 4469
10  com.apple.CoreFoundation         0x9011dcf8 CFRunLoopRunInMode + 88
11  com.apple.HIToolbox              0x96e15da4 RunCurrentEventLoopInMode + 283
12  com.apple.HIToolbox              0x96e15bbd ReceiveNextEventCommon + 374
13  com.apple.HIToolbox              0x96e15a31 BlockUntilNextEventMatchingListInMode + 106
14  com.apple.AppKit                 0x90daa505 _DPSNextEvent + 657
15  com.apple.AppKit                 0x90da9db8 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 128
16  com.apple.AppKit                 0x90da2df3 -[NSApplication run] + 795
17  com.apple.AppKit                 0x90d70030 NSApplicationMain + 574
18  com.adiumX.adiumX                0x00003522 _start + 216
19  com.adiumX.adiumX                0x00003449 start + 41



But i can use adium b9 unoffical,who can give me a download url ,thanx!

lukeoldboy
Harmless
Posts: 2
Joined: Sun Aug 17, 2008 1:45 pm

Re: UNOFFICIAL Adium with msnp15 testing

Postby lukeoldboy » Sun Aug 17, 2008 1:59 pm

[edit]
Last edited by lukeoldboy on Sun Aug 17, 2008 8:12 pm, edited 1 time in total.

User avatar
Dimmuxx
Crema
Posts: 359
Joined: Mon Apr 21, 2008 1:42 pm
Location: Sweden

Re: UNOFFICIAL Adium with msnp15 testing

Postby Dimmuxx » Sun Aug 17, 2008 4:02 pm

lukeoldboy wrote:Hello, it's my first message here! I'm using adium 1.3b11 exclusively with msn protocol (thank you for the personal messages support!), it works fine, except for a crash occurring every time I'm talking with a specific contact (using amsn on mac). The scenario: we begin a chat, and I don't close the window (let's suppose I leave the room...): if I just click on the window after a while (5-10 mins), adium always crashes.


You are running the official beta or at least not one of my builds so why do you write about it here? If you are running the official beta(the one on beta.adiumx.com) which it looks like you do you should report this problem to trac.

lukeoldboy
Harmless
Posts: 2
Joined: Sun Aug 17, 2008 1:45 pm

Re: UNOFFICIAL Adium with msnp15 testing

Postby lukeoldboy » Sun Aug 17, 2008 8:11 pm

Oops! I'm sorry, you're right. I've just googled for something like "adium b11 crashes" , looking for a solution to my problem...

Sorry again

hippy dave
Muffin
Posts: 49
Joined: Wed Sep 12, 2007 2:49 am

Re: UNOFFICIAL Adium with msnp15 testing

Postby hippy dave » Tue Aug 19, 2008 11:46 pm

well i haven't had any more slp crashes (or any other crashes) since updating to your latest build a few days ago :)

User avatar
Dimmuxx
Crema
Posts: 359
Joined: Mon Apr 21, 2008 1:42 pm
Location: Sweden

Re: UNOFFICIAL Adium with msnp15 testing

Postby Dimmuxx » Wed Aug 20, 2008 1:51 am

hippy dave wrote:well i haven't had any more slp crashes (or any other crashes) since updating to your latest build a few days ago :)


That's great! :grin:

Fun fact: Pidgin 2.5.0 with msnp15 was released today and the only major protocol that people haven't found any big problems with is msn so it seems that all the testing did pay off. :)

blubi
Harmless
Posts: 9
Joined: Sat Aug 09, 2008 3:23 pm
Location: Switzerland

Re: UNOFFICIAL Adium with msnp15 testing

Postby blubi » Wed Aug 20, 2008 5:42 am

Dimmuxx wrote:
Sure, why not. A slp* crash was fixed today btw so I'll do a new build soon.

Edit: New build is out and let's hope this one built correctly for ppc. Please report if the timestamps work correctly too.


Hi Dimmuxx

Thx for the new build. Just have installed it and seems to work on ppc. Also timestamps are back. That's great.
:grin:
G5, Mac OS 10.5.8

User avatar
David Munch
Grandé
Posts: 892
Joined: Sun Dec 05, 2004 3:41 pm
Location: Denmark
Contact:

Re: UNOFFICIAL Adium with msnp15 testing

Postby David Munch » Wed Aug 20, 2008 8:33 am

Dimmuxx wrote:
hippy dave wrote:well i haven't had any more slp crashes (or any other crashes) since updating to your latest build a few days ago :)


That's great! :grin:

Fun fact: Pidgin 2.5.0 with msnp15 was released today and the only major protocol that people haven't found any big problems with is msn so it seems that all the testing did pay off. :)

Interesting. How did the MSNP15 for 10.4 users go out in the end? MSNP15 in a 1.3.x update, or won't they get it at all?
For Vienna issues: Please search Github before posting! Otherwise, file a bug report on Github.

If you are interested in helping out with the development of Vienna, see the Vienna website for details. All levels of programming experience are welcome! :grin:

User avatar
Dimmuxx
Crema
Posts: 359
Joined: Mon Apr 21, 2008 1:42 pm
Location: Sweden

Re: UNOFFICIAL Adium with msnp15 testing

Postby Dimmuxx » Wed Aug 20, 2008 10:27 am

David Munch wrote:Interesting. How did the MSNP15 for 10.4 users go out in the end? MSNP15 in a 1.3.x update, or won't they get it at all?


The current plan is to include it in a 1.3.x update but this might change.

neckaros
Harmless
Posts: 18
Joined: Mon Jun 16, 2008 10:06 am

Re: UNOFFICIAL Adium with msnp15 testing

Postby neckaros » Fri Aug 22, 2008 6:24 pm

No news good news!
This build seems pretty stable. I hope msnp15 gets included in 1.3.1

markes
Muffin
Posts: 31
Joined: Sun Sep 17, 2006 11:51 pm

Re: UNOFFICIAL Adium with msnp15 testing

Postby markes » Fri Aug 22, 2008 8:47 pm

Adium team, we hope you prioritize MSN more. We know you are not using it and we know it depends on Pidgin, but whole Europe are using MSN mainly. Proper MSN support will make Adium a LOT better.

:| :)

User avatar
David Munch
Grandé
Posts: 892
Joined: Sun Dec 05, 2004 3:41 pm
Location: Denmark
Contact:

Re: UNOFFICIAL Adium with msnp15 testing

Postby David Munch » Sat Aug 23, 2008 9:29 am

markes wrote:Adium team, we hope you prioritize MSN more. We know you are not using it and we know it depends on Pidgin, but whole Europe are using MSN mainly. Proper MSN support will make Adium a LOT better.

:| :)

MSN works fine for me. It can send *gasp* messages.
For Vienna issues: Please search Github before posting! Otherwise, file a bug report on Github.

If you are interested in helping out with the development of Vienna, see the Vienna website for details. All levels of programming experience are welcome! :grin:

User avatar
Catfish_Man
Cocoaforge Admin
Posts: 1203
Joined: Thu Dec 02, 2004 6:30 am
Location: Portland, Oregon
Contact:

Re: UNOFFICIAL Adium with msnp15 testing

Postby Catfish_Man » Sun Aug 24, 2008 7:02 am

markes wrote:Adium team, we hope you prioritize MSN more. We know you are not using it and we know it depends on Pidgin, but whole Europe are using MSN mainly. Proper MSN support will make Adium a LOT better.

:| :)


I'm not sure how we *could* prioritize it more than we are at the moment, considering there's two projects (msn-pecan and libpurple's msnp15) both moving specifically it forward, as opposed to 0 specific projects for the other protocols. We may hate it (I certainly do), but since we're forced to support it, it may as well work well.

neckaros
Harmless
Posts: 18
Joined: Mon Jun 16, 2008 10:06 am

Re: UNOFFICIAL Adium with msnp15 testing

Postby neckaros » Mon Aug 25, 2008 10:00 am

David Munch wrote:MSN works fine for me. It can send *gasp* messages.

my typewriter worked just fine! i don't know why i buy a Mac *gasp* ;)

User avatar
David Munch
Grandé
Posts: 892
Joined: Sun Dec 05, 2004 3:41 pm
Location: Denmark
Contact:

Re: UNOFFICIAL Adium with msnp15 testing

Postby David Munch » Mon Aug 25, 2008 1:10 pm

neckaros wrote:
David Munch wrote:MSN works fine for me. It can send *gasp* messages.

my typewriter worked just fine! i don't know why i buy a Mac *gasp* ;)

The games my friend, the games... :razz:
For Vienna issues: Please search Github before posting! Otherwise, file a bug report on Github.

If you are interested in helping out with the development of Vienna, see the Vienna website for details. All levels of programming experience are welcome! :grin:


Return to “Adium”

Who is online

Users browsing this forum: No registered users