UNOFFICIAL Adium with msnp15 testing

An instant messenger which can connect to AIM, GTalk, Jabber, ICQ, and more.
Zelgadis
Harmless
Posts: 2
Joined: Sun Aug 03, 2008 10:56 pm

Re: UNOFFICIAL Adium with msnp15 testing

Postby Zelgadis » Sun Aug 03, 2008 11:23 pm

Dimmuxx wrote:
Zelgadis wrote:Hmm.. I can't see status messages anymore with this build.. :(


Probably this bug then http://trac.adiumx.com/ticket/10611.


Argh, what a bad regression :(
Hope it will be fixed soon ^^

User avatar
SLMalling
Harmless
Posts: 16
Joined: Mon Jun 16, 2008 9:01 pm
Location: Vejle, Denmark
Contact:

Re: UNOFFICIAL Adium with msnp15 testing

Postby SLMalling » Mon Aug 04, 2008 6:13 pm

:!: I don't know if this is just me, but if i go to "preferences" and to the (messages) icon to change the look of my message windows this version goes to 100% cpu and stops responding.... anyone else seeing this??

User avatar
IUG
Latté
Posts: 53
Joined: Thu Jun 16, 2005 1:01 am

Re: UNOFFICIAL Adium with msnp15 testing

Postby IUG » Mon Aug 04, 2008 10:36 pm

SLMalling wrote::!: I don't know if this is just me, but if i go to "preferences" and to the (messages) icon to change the look of my message windows this version goes to 100% cpu and stops responding.... anyone else seeing this??

I just tried that, not a hickup. Try to remove some display settings, or deleting your preferences for Adium.

Here's an odd one to report. My friend's away message displayed the 8-) as :-| instead. Minor thing, but it made me wonder why she would be so "sad" about going to see her favorite band in concert that night.

User avatar
Robby
Cocoaforge Admin
Posts: 2606
Joined: Mon May 01, 2006 3:00 am

Re: UNOFFICIAL Adium with msnp15 testing

Postby Robby » Mon Aug 04, 2008 11:14 pm

IUG wrote:
SLMalling wrote:[...]My friend's away message displayed the 8-) as :-| instead. Minor thing, but it made me wonder why she would be so "sad" about going to see her favorite band in concert that night.

Try that in a normal chat, it's the same there. Curiously, it was also today, that I noticed that.
I'd consider that worth a bug report. This example of emoticon parsing seems wrong to me.

The Joker
Harmless
Posts: 3
Joined: Tue Aug 05, 2008 12:31 am

Re: UNOFFICIAL Adium with msnp15 testing

Postby The Joker » Tue Aug 05, 2008 12:37 am

I just installed the latest beta hoping that it would solve the crashes I saw in the previous beta. Unfortunately the same crash appears. It's after I've been speaking with one of my friends and they go offline - Adium crashes. Here's the relevant info from the crash report:

Exception Type: EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x0000000080000000
Crashed Thread: 0

Thread 0 Crashed:
0 ...s.openspecies.rtool.libglib 0x177e93b2 g_queue_is_empty + 65
1 libpurple 0x17971473 msn_switchboard_close + 90
2 libpurple 0x17971542 msn_switchboard_release + 116
3 libpurple 0x1796b72c msn_slplink_remove_slpcall + 77
4 libpurple 0x1796b023 msn_slp_call_destroy + 209
5 libpurple 0x1796b2cd msn_slp_call_timeout + 43
6 com.adiumX.AdiumPurple 0x17708113 callTimerFunc + 120
7 com.apple.CoreFoundation 0x92bdeb45 CFRunLoopRunSpecific + 4469
8 com.apple.CoreFoundation 0x92bdecf8 CFRunLoopRunInMode + 88
9 com.apple.HIToolbox 0x93c12da4 RunCurrentEventLoopInMode + 283
10 com.apple.HIToolbox 0x93c12bbd ReceiveNextEventCommon + 374
11 com.apple.HIToolbox 0x93c12a31 BlockUntilNextEventMatchingListInMode + 106
12 com.apple.AppKit 0x94b78505 _DPSNextEvent + 657
13 com.apple.AppKit 0x94b77db8 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 128
14 com.apple.AppKit 0x94b70df3 -[NSApplication run] + 795
15 com.apple.AppKit 0x94b3e030 NSApplicationMain + 574
16 com.adiumX.adiumX 0x00003322 _start + 216
17 com.adiumX.adiumX 0x00003249 start + 41

I can see the crash is in libpurple and not Adium - but I thought I'd report it anyway. Thanks for putting this build together! :)

PS If it will help I do have the debug log - I didn't paste it this time simply because it was libpurple that crashed. If you want that log though then I can certainly paste it!

User avatar
Robby
Cocoaforge Admin
Posts: 2606
Joined: Mon May 01, 2006 3:00 am

Re: UNOFFICIAL Adium with msnp15 testing

Postby Robby » Tue Aug 05, 2008 12:45 am

The Joker wrote:I just installed the latest beta hoping that it would solve the crashes I saw in the previous beta. Unfortunately the same crash appears.

The Joker wrote:Thanks for putting this build together! :)

PS If it will help I do have the debug log - I didn't paste it this time simply because it was libpurple that crashed. If you want that log though then I can certainly paste it!

Beta, this build - and all that in this thread?

What is it you're using, The Joker, the official beta (b10) or the unofficial builds by Dimmuxx?

The Joker
Harmless
Posts: 3
Joined: Tue Aug 05, 2008 12:31 am

Re: UNOFFICIAL Adium with msnp15 testing

Postby The Joker » Tue Aug 05, 2008 1:03 am

This unofficial build (1.3b10-246) that I downloaded from the link on the first page of this thread. Sorry for any confusion. :)

I've been doing some digging and the closest bug on trac was ticket 10348 (http://trac.adiumx.com/ticket/10348). It's not exactly the same callstack though but...

Anyway, in case it helps here is the end of the log before it crashed. I've edited the email addresses and so on just because it seems sensible:

Code: Select all

01:22:07: (Libpurple: msn) switchboard send msg..
01:22:07: (Libpurple: msn) C: SB 025: MSG 327 D 152
01:22:07: (Libpurple: msn) S: SB 025: ACK 327
01:22:54: (Libpurple: msn) C: NS 000: PNG
01:22:54: (Libpurple: msn) S: NS 000: QNG 46
01:22:57: (Libpurple: msn) S: SB 025: MSG xxxxx@hotmail.com xxxxx 653
01:22:57: (Libpurple: msn) switchboard send msg..
01:22:57: (Libpurple: msn) C: SB 025: MSG 328 D 152
01:22:57: (Libpurple: msn) S: SB 025: ACK 328
01:23:17: (Libpurple: msn) S: SB 025: BYE xxxxx@hotmail.com
01:23:17: (Libpurple: msn) destroy httpconn (0x1c9a3c30)
01:23:24: (Libpurple: msn) C: NS 000: PNG
01:23:25: (Libpurple: msn) S: NS 000: QNG 43
01:24:24: (Libpurple: msn) C: NS 000: PNG
01:24:24: (Libpurple: msn) S: NS 000: QNG 49
01:24:54: (Libpurple: msn) C: NS 000: PNG
01:24:54: (Libpurple: msn) S: NS 000: QNG 43
01:25:24: (Libpurple: msn) C: NS 000: PNG
01:25:24: (Libpurple: msn) S: NS 000: QNG 48
01:25:54: (Libpurple: msn) C: NS 000: PNG
01:25:54: (Libpurple: msn) S: NS 000: QNG 49
01:26:22: <ESPurpleMSNAccount:1763d970 1>:xxxxx@hotmail.com: privacyOptions are 1
01:26:22: Because of privacy option 1, resizing from {{458, 648}, {393, 344}} to {{458, 860}, {393, 132}}
01:26:24: (Libpurple: msn) C: NS 000: PNG
01:26:24: (Libpurple: msn) S: NS 000: QNG 46
01:26:33: (Libpurple: msn) S: NS 000: NLN NLN xxxxx@mailbox.gr 1 xxxxx 2254295084 %3Cmsnobj%20Creator%3D%22xxxxx%40mailbox.gr%22%20Type%3D%223%22%20SHA1D%3D%22xCBtVhZiL7rx1uGfPGSbnFXgEwg%3D%22%20Size%3D%222917%22%20Location%3D%220%22%20Friendly%3D%22cAByAHMAAAA%3D%22%2F%3E
01:26:33: (Libpurple: blist) Updating buddy status for xxxxx@mailbox.gr (MSN)
01:26:33: -[AIPreferenceContainer prefs]: I read in ByObjectPrefs with 163 items
01:26:48: -[AdiumPreferredAccounts preferredAccountForSendingContentType:toContact:]: Could not find an online choice to talk to <AIListContact:1a7567c0 MSN.xxxxx@hotmail.com>; will include offline accounts
01:26:48: <ESPurpleMSNAccount:1763d970 1>:xxxxx@hotmail.com: privacyOptions are 1
01:26:54: (Libpurple: msn) S: NS 000: NLN BSY xxxxx@mailbox.gr 1 xxxxx 2254295084 %3Cmsnobj%20Creator%3D%22xxxxx%40mailbox.gr%22%20Type%3D%223%22%20SHA1D%3D%22xCBtVhZiL7rx1uGfPGSbnFXgEwg%3D%22%20Size%3D%222917%22%20Location%3D%220%22%20Friendly%3D%22cAByAHMAAAA%3D%22%2F%3E
01:26:54: (Libpurple: blist) Updating buddy status for xxxxx@mailbox.gr (MSN)

User avatar
Dimmuxx
Crema
Posts: 359
Joined: Mon Apr 21, 2008 1:42 pm
Location: Sweden

Re: UNOFFICIAL Adium with msnp15 testing

Postby Dimmuxx » Tue Aug 05, 2008 1:11 am

There are two crash bugs reported for pidgin/libpurple. It seems that your crash are related to them The Joker.

http://developer.pidgin.im/ticket/6441
http://developer.pidgin.im/ticket/6469

The Joker
Harmless
Posts: 3
Joined: Tue Aug 05, 2008 12:31 am

Re: UNOFFICIAL Adium with msnp15 testing

Postby The Joker » Tue Aug 05, 2008 1:22 am

Yes, yes they do. I didn't really think it was a problem in your code - I just wanted to mention the bug just in case.

Thanks for looking! :)

User avatar
Dimmuxx
Crema
Posts: 359
Joined: Mon Apr 21, 2008 1:42 pm
Location: Sweden

Re: UNOFFICIAL Adium with msnp15 testing

Postby Dimmuxx » Tue Aug 05, 2008 1:30 am

The Joker wrote:Yes, yes they do. I didn't really think it was a problem in your code - I just wanted to mention the bug just in case.

Thanks for looking! :)


Libpurple is the code that I'm poking around in mostly. ;)

User avatar
mascker
Harmless
Posts: 12
Joined: Tue May 03, 2005 11:20 pm

re:

Postby mascker » Tue Aug 05, 2008 2:48 am

TO BE REMOVED
Last edited by mascker on Sat Sep 04, 2010 10:05 pm, edited 1 time in total.

User avatar
Dimmuxx
Crema
Posts: 359
Joined: Mon Apr 21, 2008 1:42 pm
Location: Sweden

Re: UNOFFICIAL Adium with msnp15 testing

Postby Dimmuxx » Tue Aug 05, 2008 11:38 am

mascker wrote:Hi,

Where can I download the previous build?

I can't see PM on this one

Regards,


http://www.mediafire.com/?hcbmmcewx0f

User avatar
Dimmuxx
Crema
Posts: 359
Joined: Mon Apr 21, 2008 1:42 pm
Location: Sweden

Re: UNOFFICIAL Adium with msnp15 testing

Postby Dimmuxx » Fri Aug 08, 2008 1:31 pm

New build is out! :bitchin:

This fixes some crashes and might have fixed some of the slp* crashes so please try it.

I had to change the build process for this one since the command line building seems to be broken atm but I think I did everything right. Please report any problems with it especially ppc users.

User avatar
Dimmuxx
Crema
Posts: 359
Joined: Mon Apr 21, 2008 1:42 pm
Location: Sweden

Re: UNOFFICIAL Adium with msnp15 testing

Postby Dimmuxx » Fri Aug 08, 2008 11:58 pm

Adium crashes when I disconnect from the msn account can anybody confirm the same thing happening with the latest build?

Edit: Fixed in the updated version of 24697!

It seems that I can't see most of other people's status messages after using the icq md5 patch for icq users. Can anybody confirm this?
Last edited by Dimmuxx on Sat Aug 09, 2008 11:32 am, edited 2 times in total.

Kayne
Harmless
Posts: 10
Joined: Thu Jun 19, 2008 4:53 pm

Re: UNOFFICIAL Adium with msnp15 testing

Postby Kayne » Sat Aug 09, 2008 3:49 am

Just wanted to point this out:

A friend of mine told me, that she is seeing the "(User) is typing" only for 2-3 seconds when she's chatting with me. Then the typing message disappears. And suddenly my message appears then, when I'm finished after, say, 10 seconds, without seeing her me typing.

Don't know if a log would be of any help in this case...
She uses Live Messenger, btw

User avatar
Dimmuxx
Crema
Posts: 359
Joined: Mon Apr 21, 2008 1:42 pm
Location: Sweden

Re: UNOFFICIAL Adium with msnp15 testing

Postby Dimmuxx » Sat Aug 09, 2008 10:54 am

I uploaded a new version of 24697 in which I reverted a change that caused Adium to crash on disconnecting msn. It also includes some extra and new msn fixes so download it again! :bitchin:

blubi
Harmless
Posts: 9
Joined: Sat Aug 09, 2008 3:23 pm
Location: Switzerland

Re: UNOFFICIAL Adium with msnp15 testing

Postby blubi » Sat Aug 09, 2008 3:34 pm

Hi
I've just installed your newest build (24697).
Adium crashes the moment i want to start it up. here is the crash report:

Code: Select all

Exception Type:  EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000001, 0x000000008fe0105c
Crashed Thread:  0

Dyld Error Message:
  Library not loaded: @executable_path/../Frameworks/FriBidi.framework/Versions/A/FriBidi
  Referenced from: /Applications/Adium.app/Contents/MacOS/Adium
  Reason: no suitable image found.  Did find:
   /Applications/Adium.app/Contents/MacOS/../Frameworks/FriBidi.framework/Versions/A/FriBidi: mach-o, but wrong architecture
   /Applications/Adium.app/Contents/MacOS/../Frameworks/FriBidi.framework/Versions/A/FriBidi: mach-o, but wrong architecture


Being PPC G5 user on Mac OS 10.5.4.
For the current, i am going back to the previous build i used (24342) which works well for me.

thx for your fantastic work!

jakudo
Muffin
Posts: 26
Joined: Fri Jun 27, 2008 8:12 am
Location: Czech Republic
Contact:

Re: UNOFFICIAL Adium with msnp15 testing

Postby jakudo » Sat Aug 09, 2008 3:51 pm

It happened to me too, but I start it up again and it's working :)

Thank you, good job!

User avatar
Dimmuxx
Crema
Posts: 359
Joined: Mon Apr 21, 2008 1:42 pm
Location: Sweden

Re: UNOFFICIAL Adium with msnp15 testing

Postby Dimmuxx » Sat Aug 09, 2008 3:56 pm

I have no idea why that happend. I haven't touched that code and I think I build everything correctly in Xcode. I just selected Deployment-Debug in it. I'm used to compile it via the console but that doesn't work any longer so I had to use Xcode. But if it only requires a restart to make it work it might just be some weird bug and otherwise you can copy FriBidi from the official beta to this one.

jakudo
Muffin
Posts: 26
Joined: Fri Jun 27, 2008 8:12 am
Location: Czech Republic
Contact:

Re: UNOFFICIAL Adium with msnp15 testing

Postby jakudo » Sat Aug 09, 2008 4:18 pm

ok, but how can I copy FriBidi from official? I have the Apple and Mac OS just few weeks and I have no idea how to do it (sorry for stupid question).


Return to “Adium”

Who is online

Users browsing this forum: No registered users