MSN custom emoticons and status messages not showing

An instant messenger which can connect to AIM, GTalk, Jabber, ICQ, and more.
Post Reply
cresur
Harmless
Posts: 3
Joined: Tue Jul 08, 2008 7:51 pm

MSN custom emoticons and status messages not showing

Post by cresur »

Hello,

I've always had "Display custom emoticons" and "Show Status Messages" enabled, but it never worked. I am using the latest version of Adium and OS X 10.5.4.

Any ideas how to solve this?
User avatar
David Munch
Grandé
Posts: 892
Joined: Sun Dec 05, 2004 3:41 pm
Location: Denmark
Contact:

Re: MSN custom emoticons and status messages not showing

Post by David Munch »

What happens when you get a custom emoticon send?
For Vienna issues: Please search Github before posting! Otherwise, file a bug report on Github.

If you are interested in helping out with the development of Vienna, see the Vienna website for details. All levels of programming experience are welcome! :grin:
cresur
Harmless
Posts: 3
Joined: Tue Jul 08, 2008 7:51 pm

Re: MSN custom emoticons and status messages not showing

Post by cresur »

David Munch wrote:What happens when you get a custom emoticon send?
It just comes as plain text. Like /hugs, etc. Actually, even native emoticons come like that. (K), ^o), |-), etc.
cresur
Harmless
Posts: 3
Joined: Tue Jul 08, 2008 7:51 pm

Re: MSN custom emoticons and status messages not showing

Post by cresur »

No one?
Drpunch
Harmless
Posts: 1
Joined: Wed Jul 16, 2008 11:58 pm

Re: MSN custom emoticons and status messages not showing

Post by Drpunch »

I get the same problem with status messages not showing. It is rather annoying, and I wish I could see them. Using latest version and OSX 10.5.4.
cm0901
Muffin
Posts: 29
Joined: Tue Feb 14, 2006 12:38 pm
Contact:

Re: MSN custom emoticons and status messages not showing

Post by cm0901 »

AFAIK Adium still doesn't support status messages, since Libpurple only support MSNP9. That's why I still use aMSN.
User avatar
evands
Cocoaforge Admin
Posts: 3152
Joined: Thu Dec 02, 2004 10:55 pm
Location: Decatur, GA
Contact:

Re: MSN custom emoticons and status messages not showing

Post by evands »

cm0901 wrote:AFAIK Adium still doesn't support status messages, since Libpurple only support MSNP9. That's why I still use aMSN.
beta.adiumx.com
The duck still burns.
--
My company: Saltatory Software. Check it out :)
cm0901
Muffin
Posts: 29
Joined: Tue Feb 14, 2006 12:38 pm
Contact:

Re: MSN custom emoticons and status messages not showing

Post by cm0901 »

I'm sorry, I haven't been following the beta process for months.
User avatar
evands
Cocoaforge Admin
Posts: 3152
Joined: Thu Dec 02, 2004 10:55 pm
Location: Decatur, GA
Contact:

Re: MSN custom emoticons and status messages not showing

Post by evands »

cm0901 wrote:I'm sorry, I haven't been following the beta process for months.
No worries. The current beta does implement MSN personal (status) messages.
The duck still burns.
--
My company: Saltatory Software. Check it out :)
sllapur
Harmless
Posts: 9
Joined: Mon Jul 21, 2008 7:26 am

Re: MSN custom emoticons and status messages not showing

Post by sllapur »

How about custom emoticons? They don't show up for me except in the form of "(something)"...

I'm using aduim 1.3b7. Is it supposed to support custom emoticons?
User avatar
evands
Cocoaforge Admin
Posts: 3152
Joined: Thu Dec 02, 2004 10:55 pm
Location: Decatur, GA
Contact:

Re: MSN custom emoticons and status messages not showing

Post by evands »

Yes, it should.

What emoticon pack(s) do you have enabled in Adium's General Preferences?
The duck still burns.
--
My company: Saltatory Software. Check it out :)
sllapur
Harmless
Posts: 9
Joined: Mon Jul 21, 2008 7:26 am

Re: MSN custom emoticons and status messages not showing

Post by sllapur »

MSN Animated + Customs is the name of the Setting...
User avatar
evands
Cocoaforge Admin
Posts: 3152
Joined: Thu Dec 02, 2004 10:55 pm
Location: Decatur, GA
Contact:

Re: MSN custom emoticons and status messages not showing

Post by evands »

You should be receiving custom emoticons, then. Please show us the debug log of a contact sending you a message with a custom emoticon he/she has set. See trac.adiumx.com/wiki/ReportingBugs for details on reporting a bug.
The duck still burns.
--
My company: Saltatory Software. Check it out :)
sllapur
Harmless
Posts: 9
Joined: Mon Jul 21, 2008 7:26 am

Re: MSN custom emoticons and status messages not showing

Post by sllapur »

I'm sorry I'm not sure what the instructions in the website you linked want me to do exactly, I'm not source-intelligent...

This is the bug report:

19:20:58: (Libpurple: msn) /Users/evands/pidgin-for-adium/libpurple/protocols/msn_pecan/cmd/cmdproc.c:275:msn_cmdproc_process_cmd() begin
19:20:58: (Libpurple: msn) /Users/evands/pidgin-for-adium/libpurple/protocols/msn_pecan/cmd/cmdproc.c:340:msn_cmdproc_process_cmd() end
19:20:58: pyro_arson_fool@hotmail.com: Added Custom Smiley xd
19:20:58: (Libpurple: msn) /Users/evands/pidgin-for-adium/libpurple/protocols/msn_pecan/cmd/msg.c:819:msn_message_show_readable() info=[SLP INVITE],str=[MIME-Version: 1.0
Content-Type: application/x-msnmsgrp2p
P2P-Dest: pyro_arson_fool@hotmail.com

Session ID: 0
ID: 750597396
Offset: 0
Total size: 638
Length: 638
Flags: 0x0
ACK ID: 1859468872
SUB ID: 0
ACK Size: 0
Footer: 0
]
19:20:58: (Libpurple: msn) /Users/evands/pidgin-for-adium/libpurple/protocols/msn_pecan/cmd/cmdproc.c:99:show_debug_cmd() C: 000: MSG 25 D 790
Post Reply