frequent connect/disconnect

An instant messenger which can connect to AIM, GTalk, Jabber, ICQ, and more.
Post Reply
angelochen960
Harmless
Posts: 1
Joined: Mon Jul 21, 2008 5:29 am

frequent connect/disconnect

Post by angelochen960 »

Hi,

When my mac is idle, there are frequent connect/disconnect activities, very annoying to people in my contact list as they see me on and off every minute. any idea how to stop this? thanks,

11:52You have connected
11:53You have disconnected
11:53You have connected
11:54You have disconnected
11:54You have connected
11:55You have disconnected
11:55You have connected
11:56You have disconnected
11:57You have connected
11:57You have disconnected
11:58You have connected
11:58You have disconnected
11:59You have connected
11:59You have disconnected
12:00You have connected
12:00You have disconnected
12:01You have connected
12:01You have disconnected
12:02You have connected
12:02You have disconnected
gls2ro
Harmless
Posts: 1
Joined: Mon Jul 21, 2008 12:00 pm

Re: frequent connect/disconnect

Post by gls2ro »

Hello,

I have the same issue with connecting and disconnecting on Jabber Server.

Also I noticed that this happens also when I close the lid of my MacBook and then open it after 2-3 minutes.


Does anyone know how to fix this?

Thank you
User avatar
evands
Cocoaforge Admin
Posts: 3152
Joined: Thu Dec 02, 2004 10:55 pm
Location: Decatur, GA
Contact:

Re: frequent connect/disconnect

Post by evands »

angelochen960, what service(s) are you using?

Please try the current AdiumBeta and report back - beta.adiumx.com
The duck still burns.
--
My company: Saltatory Software. Check it out :)
us3r
Harmless
Posts: 1
Joined: Wed Aug 13, 2008 7:58 pm

Re: frequent connect/disconnect

Post by us3r »

I have this same problem with adium. Three weeks ago everything was ok. But now when i'm connecting to chrome.pl all the time i have this problem. Sometimes i can connect with jabber server on first time. If I use PSI to connect with chrome.pl everythings is ok. At the moment i'm use adium 1.2.7.


Sorry for my english ;)
User avatar
Robby
Cocoaforge Admin
Posts: 2607
Joined: Mon May 01, 2006 3:00 am

Re: frequent connect/disconnect

Post by Robby »

us3r, we cannot help you if you do not follow evands' instructions.
taediumlentesco
Harmless
Posts: 1
Joined: Thu Sep 04, 2008 1:02 am

Re: frequent connect/disconnect

Post by taediumlentesco »

I have this same problem on Adium 1.3 with my MyspaceIM, AIM and GTalk accounts. getting quite irritating. There's no error message, just consistent disconnections/connections. Any help would be greatly appreciated!
User avatar
zac
Cocoaforge Admin
Posts: 1518
Joined: Sun Mar 27, 2005 3:19 pm
Contact:

Re: frequent connect/disconnect

Post by zac »

taediumlentesco wrote:I have this same problem on Adium 1.3 with my MyspaceIM, AIM and GTalk accounts. getting quite irritating. There's no error message, just consistent disconnections/connections. Any help would be greatly appreciated!
Error messages don't display unless it's a fatal disconnection error (i.e., one which reconnecting cannot fix, such as invalid password). Open the Accounts preference pane and see what error message is under the account.
gneGne
Harmless
Posts: 2
Joined: Fri Sep 05, 2008 7:14 pm

Re: frequent connect/disconnect

Post by gneGne »

So, I am also having frequent disconnects but I am getting an error message.
I've had this with 1.3 and now also with 1.3b2. This happens when Im surfing/idling, and not while using Adium.

Should I post the error msg? thanks.
Last edited by gneGne on Fri Sep 05, 2008 7:23 pm, edited 1 time in total.
User avatar
zac
Cocoaforge Admin
Posts: 1518
Joined: Sun Mar 27, 2005 3:19 pm
Contact:

Re: frequent connect/disconnect

Post by zac »

gneGne wrote:So, I am also having frequent disconnects but I am getting an error message. I've had this with 1.3 and now also with 1.3b2. Should I post the error msg? thanks.
Well uh…yes…
gneGne
Harmless
Posts: 2
Joined: Fri Sep 05, 2008 7:14 pm

Re: frequent connect/disconnect

Post by gneGne »

Process: Adium [123]
Path: /Applications/Adium.app/Contents/MacOS/Adium
Identifier: com.adiumX.adiumX
Version: 1.3.1b2 (1.3.1b2)
Code Type: X86 (Native)
Parent Process: launchd [60]

Date/Time: 2008-09-05 21:30:46.763 +0200
OS Version: Mac OS X 10.5.4 (9E17)
Report Version: 6

Exception Type: EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x000000002444c7e4
Crashed Thread: 0

Thread 0 Crashed:
0 libglib 0x178ef04c g_list_remove + 23
1 libpurple 0x17a8866d msn_slpmsg_destroy + 188
2 libpurple 0x17a8809f msn_slplink_process_msg + 1307
3 libpurple 0x17a85f57 msn_p2p_msg + 183
4 libpurple 0x17a799d8 msn_cmdproc_process_msg + 211
5 libpurple 0x17a746f0 msg_cmd_post + 111
6 libpurple 0x17a798ff msn_cmdproc_process_payload + 142
7 libpurple 0x17a8196e parse_impl + 456
8 libpurple 0x17a806e9 pecan_node_parse + 36
9 libpurple 0x17a7ff70 read_cb + 378
10 libglib 0x17931832 g_io_unix_dispatch + 137
11 libglib 0x178f2506 g_main_dispatch + 498
12 libglib 0x178f3aa8 g_main_context_dispatch + 138
13 libglib 0x178f4033 g_main_context_iterate + 1312
14 libglib 0x178f4273 g_main_context_iteration + 163
15 com.apple.CoreFoundation 0x910869c2 __CFRunLoopDoObservers + 466
16 com.apple.CoreFoundation 0x91087d32 CFRunLoopRunSpecific + 866
17 com.apple.CoreFoundation 0x91088cf8 CFRunLoopRunInMode + 88
18 com.apple.HIToolbox 0x92bcdda4 RunCurrentEventLoopInMode + 283
19 com.apple.HIToolbox 0x92bcdbbd ReceiveNextEventCommon + 374
20 com.apple.HIToolbox 0x92bcda31 BlockUntilNextEventMatchingListInMode + 106
21 com.apple.AppKit 0x94c65505 _DPSNextEvent + 657
22 com.apple.AppKit 0x94c64db8 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 128
23 com.apple.AppKit 0x94c5ddf3 -[NSApplication run] + 795
24 com.apple.AppKit 0x94c2b030 NSApplicationMain + 574
25 com.adiumX.adiumX 0x000029c2 _start + 216
26 com.adiumX.adiumX 0x000028e9 start + 41

Thread 1:
0 libSystem.B.dylib 0x9711f4a6 mach_msg_trap + 10
1 libSystem.B.dylib 0x97126c9c mach_msg + 72
2 com.apple.CoreFoundation 0x910880ce CFRunLoopRunSpecific + 1790
3 com.apple.CoreFoundation 0x91088cf8 CFRunLoopRunInMode + 88
4 com.apple.audio.CoreAudio 0x929fe468 HALRunLoop::OwnThread(void*) + 160
5 com.apple.audio.CoreAudio 0x929fe304 CAPThread::Entry(CAPThread*) + 96
6 libSystem.B.dylib 0x971506f5 _pthread_start + 321
7 libSystem.B.dylib 0x971505b2 thread_start + 34

Thread 2:
0 libSystem.B.dylib 0x9716f5e2 select$DARWIN_EXTSN + 10
1 libSystem.B.dylib 0x971506f5 _pthread_start + 321
2 libSystem.B.dylib 0x971505b2 thread_start + 34

Thread 3:
0 libSystem.B.dylib 0x9718907a __workq_ops + 10
1 libSystem.B.dylib 0x971890aa start_wqthread + 30

Thread 4:

Thread 5:
0 libSystem.B.dylib 0x9712668e __semwait_signal + 10
1 libSystem.B.dylib 0x9715136d pthread_cond_wait$UNIX2003 + 73
2 libGLProgrammability.dylib 0x917e2432 glvmDoWork + 162
3 libSystem.B.dylib 0x971506f5 _pthread_start + 321
4 libSystem.B.dylib 0x971505b2 thread_start + 34

Thread 0 crashed with X86 Thread State (32-bit):
eax: 0x2444c7e4 ebx: 0x17a885bd ecx: 0x00000001 edx: 0x0007a014
edi: 0x00000004 esi: 0x00000000 ebp: 0xbfffc798 esp: 0xbfffc770
ss: 0x0000001f efl: 0x00010206 eip: 0x178ef04c cs: 0x00000017
ds: 0x0000001f es: 0x0000001f fs: 0x00000000 gs: 0x00000037
cr2: 0x2444c7e4
This is it... using the newest batch of the Macbooks..
User avatar
zac
Cocoaforge Admin
Posts: 1518
Joined: Sun Mar 27, 2005 3:19 pm
Contact:

Re: frequent connect/disconnect

Post by zac »

gneGne wrote:This is it... using the newest batch of the Macbooks..
You aren't getting frequent disconnects, you're getting crashes. See http://trac.adiumx.com/wiki/ReportingBugs
dvandelay
Harmless
Posts: 14
Joined: Mon Oct 22, 2007 10:27 pm
Location: Middleton, WI
Contact:

Re: frequent connect/disconnect

Post by dvandelay »

I have also been getting frequent disconnects/connects. Seems to happen at least once an hour. I've been using Adium for years and haven't experienced this until the last few months maybe. I don't notice any disruptions with other internet-related software.

I am using Adium 1.3.2 on a MacBook Pro running 10.5.5.

I am not getting any error messages. Let me know if there is something I can do to help troubleshoot.

Thanks,
Dave
dvandelay
Harmless
Posts: 14
Joined: Mon Oct 22, 2007 10:27 pm
Location: Middleton, WI
Contact:

Re: frequent connect/disconnect

Post by dvandelay »

I opened up a ticket about this issue and included a debug log...

http://trac.adiumx.com/ticket/11391

-Dave
dvandelay
Harmless
Posts: 14
Joined: Mon Oct 22, 2007 10:27 pm
Location: Middleton, WI
Contact:

Re: frequent connect/disconnect

Post by dvandelay »

I'm now on a different internet connection (visiting family) and this issue has not occurred here. So, there's clearly something going on with my connection at home. But it still seems to only have an effect on Adium -- I never get 'lost connection' messages when sending/checking mail or using Facebook chat. When I get home next week I'll sign on to Adium with one account and iChat with another and see what happens.

-Dave
Post Reply