Unable to Add User: Unknown error (204)

An instant messenger which can connect to AIM, GTalk, Jabber, ICQ, and more.
Post Reply
firesong
Harmless
Posts: 2
Joined: Thu May 07, 2009 2:49 am

Unable to Add User: Unknown error (204)

Post by firesong »

Hi all,

I've updated to the BETA, and I've been getting this error everytime I try to connect to MSN. It's quite annoying.

Image

I have tried to run the Microsoft Messenger client to see if I might have failed to add anyone. I've also gone through my entire contact list and it would appear everything's fine. The previous version of Adium worked well, so this is definitely an issue with the Beta.

Any thoughts/tips?
sushant
Harmless
Posts: 1
Joined: Wed Jun 24, 2009 11:06 pm

Re: Unable to Add User: Unknown error (204)

Post by sushant »

Im currently having the same problem.:(
User avatar
Robby
Cocoaforge Admin
Posts: 2607
Joined: Mon May 01, 2006 3:00 am

Re: Unable to Add User: Unknown error (204)

Post by Robby »

Which version of Adium are you running?
alexz
Harmless
Posts: 2
Joined: Wed Jul 01, 2009 5:21 am

Re: Unable to Add User: Unknown error (204)

Post by alexz »

I've been having the same problem for over 6 months :(

It's version 1.3.5 running on Mac OS X 10.5.7

Anyone know what's up?

Thanks in advance for any help.
alexz
Harmless
Posts: 2
Joined: Wed Jul 01, 2009 5:21 am

Re: Unable to Add User: Unknown error (204)

Post by alexz »

Running version 1.3.5 and been having the same problem since January.

"Unable to Add User: Unknown error (204)"

F'n sucks.

Why does there seem to be no explanation for this anywhere on the world wide interwebz???

Any help appreciated!
detatched
Harmless
Posts: 7
Joined: Fri Jun 26, 2009 11:07 am

Re: Unable to Add User: Unknown error (204)

Post by detatched »

Hi,

Please see the debug log this is what happens every time I Connect My Account:

Code: Select all

17:00:42: (Libpurple: msn) C: NS 000: ADL 10 666
17:00:42: (Libpurple: msn) C: NS 000: FQY 11 119
17:00:42: (Libpurple: msn) S: NS 000: BLP 8 AL
17:00:43: (Libpurple: msn) S: NS 000: ADL 9 OK
17:00:43: (Libpurple: msn) S: NS 000: ADL 10 OK
17:00:43: (Libpurple: msn) S: NS 000: FQY 11 55
17:00:43: (Libpurple: msn) Process FQY
17:00:43: (Libpurple: msn) FQY response says username@live.com.au is from network 1
17:00:43: (Libpurple: msn) Passport: username@live.com.au, type: 1
17:00:43: (Libpurple: msn) Didn't find existing domain node, adding one.
17:00:43: (Libpurple: msn) list_op: 3
17:00:43: (Libpurple: msn) Sending ADL with payload: <ml l='1'><d n='live.com.au'><c n='username' l='3' t='1'/></d></ml>
17:00:43: (Libpurple: msn) C: NS 000: ADL 12 72
17:00:43: (Libpurple: msn) S: NS 000: FQY 11 100
17:00:43: (Libpurple: msn) Process FQY
17:00:43: (Libpurple: msn) FQY response says username@yahoo.com.au is from network 32
17:00:43: (Libpurple: msn) Passport: username@yahoo.com.au, type: 32
17:00:43: (Libpurple: msn) Didn't find existing domain node, adding one.
17:00:43: (Libpurple: msn) list_op: 3
17:00:43: (Libpurple: msn) Sending ADL with payload: <ml l='1'><d n='yahoo.com.au'><c n='username' l='3' t='32'/></d></ml>
17:00:43: (Libpurple: msn) C: NS 000: ADL 13 76
17:00:43: (Libpurple: msn) S: NS 000: FQY 11 86
17:00:43: (Libpurple: msn) Process FQY
17:00:43: (Libpurple: msn) FQY response says xxxxxxx@yahoo.com.au is from network 32
17:00:43: (Libpurple: msn) Passport: xxxxxxx@yahoo.com.au, type: 32
17:00:43: (Libpurple: msn) Didn't find existing domain node, adding one.
17:00:43: (Libpurple: msn) list_op: 3
17:00:43: (Libpurple: msn) Sending ADL with payload: <ml l='1'><d n='yahoo.com.au'><c n='xxxxxxx' l='3' t='32'/></d></ml>
17:00:43: (Libpurple: msn) C: NS 000: ADL 14 69
17:00:43: (Libpurple: msn) S: NS 000: ADL 12 OK
17:00:44: (Libpurple: msn) S: NS 000: 204 13 71
17:00:44: (Libpurple: msn) ADL error
17:00:44: adiumPurpleNotifyMessage: type: 0

Unable to add user
Unknown error (204): <ml><d n="yahoo.com.au"><c n="username" l="3" t="32" /></d></ml> 
17:00:44: Posting Growl notification: Event ID: Interface_ErrorMessageReceived, listObject: (null), chat: (null), description: Unable to add user
Unknown error (204): <ml><d n="yahoo.com.au"><c n="username" l="3" t="32" /></d></ml>
17:00:44: (Libpurple: msn) S: NS 000: 204 14 64
17:00:44: (Libpurple: msn) ADL error
17:00:44: adiumPurpleNotifyMessage: type: 0

Unable to add user
Unknown error (204): <ml><d n="yahoo.com.au"><c n="xxxxxxx" l="3" t="32" /></d></ml> 
17:00:44: Posting Growl notification: Event ID: Interface_ErrorMessageReceived, listObject: (null), chat: (null), description: Unable to add user
Unknown error (204): <ml><d n="yahoo.com.au"><c n="xxxxxxx" l="3" t="32" /></d></ml>
17:00:44: (Libpurple: msn) S: NS 000: ADL 13 OK
17:00:44: (Libpurple: msn) S: NS 000: ADL 14 OK
17:00:44: Connected: gc=1b7b7e00
17:00:44: ************ my.email@me.com CONNECTED ***********
I have Replaced the actual email address names with xxxxx, username and my.email

Can anyone help?
User avatar
Dimmuxx
Crema
Posts: 359
Joined: Mon Apr 21, 2008 1:42 pm
Location: Sweden

Re: Unable to Add User: Unknown error (204)

Post by Dimmuxx »

The only way to get rid of this problem is to delete the yahoo contacts that are causing it. This will hopefully be fixed in the core someday, see http://developer.pidgin.im/ticket/8988 for more details about the issue.
discoimp
Harmless
Posts: 1
Joined: Fri Aug 07, 2009 3:48 pm

Re: Unable to Add User: Unknown error (204)

Post by discoimp »

(edit) note: other contacts may as well show "profile not found", but the one you want has no info at all.

(solution) Hi. I've had this problem as well. I fixed it. Go to the "view" options and select view all contacts, regardless of online/offline/inactive status.
When done, go to each of the contacts you havent seen active for a while (start with these) and option-click on one at a time > select show info.

The contact that was making this problem for me was listed with ("no profile found [...] this contact may not even exist"
Delete that contact and you're good. It worked for me. (contacts e-mailadress was: [username]@yahoo.no)

-discoimp - Strike a pose!
arktouros
Harmless
Posts: 2
Joined: Tue Nov 03, 2009 10:45 am

Re: Unable to Add User: Unknown error (204)

Post by arktouros »

Hello,

I ve got the same problem and does not go away... :roll: I have Adium 1.3.7. and there is no way i can go through all of my contacts to see which one is causing it. Through the years contacts have gathered in the list and there are a lot at this point.
I know its msn that is causing the problem. By the way why is this problem not fixed yet. I think its the 3rd or 4rth update and bug is still here.
Anyone has a idea of how to find out which contact it is without going through them one by one? :b

Thank you
arktouros
Harmless
Posts: 2
Joined: Tue Nov 03, 2009 10:45 am

Re: Unable to Add User: Unknown error (204)

Post by arktouros »

I went through the log and found a contact that seems to be problematic. I click remove contact but on the next login of adium the contact re appears. And of course the error ...
Post Reply