MSN not receiving messages

An instant messenger which can connect to AIM, GTalk, Jabber, ICQ, and more.
H7P3R10N
Harmless
Posts: 9
Joined: Sat Jul 24, 2010 1:18 pm

MSN not receiving messages

Post by H7P3R10N »

I'm experiencing a problem where contacts will have sent a message, but Adium will not receive those messages. I've tried other IMers that don't have this problem, and multiple wi-fi networks that don't seem to affect when this problem occurs, so I've isolated it to Adium, but I don't know what's going on.

Any help?
wonderfishclyde
Harmless
Posts: 1
Joined: Sat Apr 04, 2009 2:06 am

Re: MSN not receiving messages

Post by wonderfishclyde »

I've been having a similar problem for a week or two now. Often I'll see someone typing a message, but then I won't get the message. Didn't microsoft release a new version of MSN recently? Maybe that has something to do with it.
User avatar
Robby
Cocoaforge Admin
Posts: 2607
Joined: Mon May 01, 2006 3:00 am

Re: MSN not receiving messages

Post by Robby »

Are there any entries from Adium in the console logging (Applications/Utilities/Console.app)?
H7P3R10N
Harmless
Posts: 9
Joined: Sat Jul 24, 2010 1:18 pm

Re: MSN not receiving messages

Post by H7P3R10N »

In Console, in 'All Messages', searching for Adium, at a time corresponding to my last login, Adium sends messages like:

"25/11/10 8:03:14 PM [0x0-0x20020].com.adiumX.adiumX[298] SocketRead: read(5) error 0
25/11/10 8:03:14 PM [0x0-0x20020].com.adiumX.adiumX[298] SocketRead err = -9802
25/11/10 8:09:07 PM [0x0-0x20020].com.adiumX.adiumX[298] SocketRead: read(5) error 0
25/11/10 8:09:07 PM [0x0-0x20020].com.adiumX.adiumX[298] SocketRead err = -9802"

I'm not sure what I'm supposed to be looking for, specifically.
User avatar
Robby
Cocoaforge Admin
Posts: 2607
Joined: Mon May 01, 2006 3:00 am

Re: MSN not receiving messages

Post by Robby »

Alright, nothing in there I was looking for.

In that case, the only possibility I can think of is that contacts of yours got blocked by mistake (http://trac.adium.im/wiki/PrivacySettings).
H7P3R10N
Harmless
Posts: 9
Joined: Sat Jul 24, 2010 1:18 pm

Re: MSN not receiving messages

Post by H7P3R10N »

Yeah, it's definitely not that. If they were blocked, I should receive no messages at all and shouldn't be able to contact them, right? My issue happens in the middle of conversations, intermittently and seemingly without reason.
Smuggler
Harmless
Posts: 2
Joined: Sat Nov 27, 2010 12:24 pm

Re: MSN not receiving messages

Post by Smuggler »

I have this issue too.
Sometimes the messages just won't reach the recipient, without any errors or whatever.
Smuggler
Harmless
Posts: 2
Joined: Sat Nov 27, 2010 12:24 pm

Re: MSN not receiving messages

Post by Smuggler »

Looking at the logs, here's what I found:

Code: Select all

28/11/10 13.28.22	[0x0-0x26026].com.adiumX.adiumX[442]	** (process:442): CRITICAL **: msn_slp_sip_recv: assertion `slpcall != NULL' failed
28/11/10 14.09.55	[0x0-0x26026].com.adiumX.adiumX[442]	** (process:442): CRITICAL **: purple_notify_close_with_handle: assertion `handle != NULL' failed
28/11/10 14.09.55	[0x0-0x26026].com.adiumX.adiumX[442]	** (process:442): CRITICAL **: purple_request_close_with_handle: assertion `handle != NULL' failed
28/11/10 14.25.19	[0x0-0x26026].com.adiumX.adiumX[442]	** (process:442): CRITICAL **: purple_notify_close_with_handle: assertion `handle != NULL' failed
28/11/10 14.25.19	[0x0-0x26026].com.adiumX.adiumX[442]	** (process:442): CRITICAL **: purple_request_close_with_handle: assertion `handle != NULL' failed
Timestamps doesn't overlap with missing messages, but are 3-4 minutes later. I don't know if this helps.
citric
Harmless
Posts: 11
Joined: Sat May 30, 2009 4:25 pm

Re: MSN not receiving messages

Post by citric »

Similar problem here: I can be having an MSN conversation where messages flow properly both ways and then the recipient's sporadically drop out (they nudge me as they thinking I've been ignoring)! Recipients aren't blocked either.

Has MSN changed a setting lately as this has never been a problem?

Running OS X 10.6.5, Adium 1.4.1 (and reinstalled).
eduardosilva
Harmless
Posts: 1
Joined: Thu Dec 02, 2010 1:43 pm

Re: MSN not receiving messages

Post by eduardosilva »

I have exactly the same issue.

Sometimes people send me messages and i don't receive, completely breaking the conversation. (i had this problem since version 1.4)

Now i can't attach any log file, because after the upgrade to version 1.4.1 my adium also crashes every few seconds....

I switched to other IM while I'm waiting for a new release of adium.
citric
Harmless
Posts: 11
Joined: Sat May 30, 2009 4:25 pm

Re: MSN not receiving messages

Post by citric »

Does something need adjusting within the Adium account settings for MSN now as I have the following (which was working perfectly on versions prior to 1.4)?

Login server: messenger.hotmail.com
Port: 1863
Connect via HTTP: checked
H7P3R10N
Harmless
Posts: 9
Joined: Sat Jul 24, 2010 1:18 pm

Re: MSN not receiving messages

Post by H7P3R10N »

Good to know I'm not the only one. It only started happening a couple of weeks ago. I'm running Adium 1.4.1, and showing all the same information as citric. I'm tried using other IMers, but Adium's just got the best UI.
User avatar
AriaPictures
Muffin
Posts: 38
Joined: Wed May 14, 2008 11:00 pm
Location: lake tahoe
Contact:

Re: MSN not receiving messages

Post by AriaPictures »

Same issue here and been going on for sometime. the biggest problem is that my wife and I communicate with each other at work this way and we keep thinking we are ignoring each other -- this is not good for the relationship.

what has changed with adium or msn to cause this to happen.

using 1.4.1
I did it, I sawed the legs of the periodic table.
citric
Harmless
Posts: 11
Joined: Sat May 30, 2009 4:25 pm

Re: MSN not receiving messages

Post by citric »

Are you guys also running OS X 10.6.5?
H7P3R10N
Harmless
Posts: 9
Joined: Sat Jul 24, 2010 1:18 pm

Re: MSN not receiving messages

Post by H7P3R10N »

Yeah, I am.
citric
Harmless
Posts: 11
Joined: Sat May 30, 2009 4:25 pm

Re: MSN not receiving messages

Post by citric »

Ok, do you also use Growl (I don't)?
H7P3R10N
Harmless
Posts: 9
Joined: Sat Jul 24, 2010 1:18 pm

Re: MSN not receiving messages

Post by H7P3R10N »

Yes, but I'm not sure where Growl would overlap with msn via Adium not giving me messages.
User avatar
H!T
Latté
Posts: 72
Joined: Wed Jan 07, 2009 10:45 pm

Re: MSN not receiving messages

Post by H!T »

Are these all isolated cases or a widespread issue? I currently have a new computer with the latest system and am afraid of installing a version of adium that wont function for me since uninstalling and downgrading back to the version i previously used (1.3.7 since it got offline AIM messages) would be a real pain along with the issue of MSN being one of the most important protocols i use and i have paranoia problems of people ignoring me and i often have serious conversations where things cant go unsaid or really bad misunderstandings happen so please tell how much an issue this is and if it will be fixed soon. :!:
citric
Harmless
Posts: 11
Joined: Sat May 30, 2009 4:25 pm

Re: MSN not receiving messages

Post by citric »

It's hard to tell: we all have the issue but how many others just aren't reporting?

I've tried a few things with the settings but still getting the drop out and only on MSN - Yahoo has been fine.
User avatar
H!T
Latté
Posts: 72
Joined: Wed Jan 07, 2009 10:45 pm

Re: MSN not receiving messages

Post by H!T »

I had recently seen someone on MacUpdates saying the same problem. Only issues with MSN Ive had in past versions of ADIUM was it sometimes randomly disconnected one of my accounts momentarily and a slow log-in that sometimes would not make it then i would have to close out and start over. I also used to regularly at certain times get error messages saying my messages werent sent but that single issue is more likely do to my poor quality ISP but who knows.
Post Reply