2 dashes to em-dash, how to disable?

An instant messenger which can connect to AIM, GTalk, Jabber, ICQ, and more.
danteand
Harmless
Posts: 8
Joined: Mon Jan 03, 2005 10:22 am

2 dashes to em-dash, how to disable?

Postby danteand » Tue Jan 18, 2011 7:59 pm

I have Adium 1.4.1 running on Mac OS X 10.6.5.
When I type two dashes in the Adium message window, they are immediately replaced with an em dash. This makes it difficult to send certain commands with two dashes for someone to copy and paste into a terminal. e.g. rsync -avn --numeric-ids --delete
becomes: rsync -avn —numeric-ids —delete

The only workaround to disable this that I have found is to go to System Preferences in Mac OS X > Languages & Text > Text
and create a new symbol and text substitution with two dashes being replaced by two dashes.

Am I missing a setting somewhere in Adium to turn off text substitution?

User avatar
zac
Cocoaforge Admin
Posts: 1518
Joined: Sun Mar 27, 2005 3:19 pm
Contact:

Re: 2 dashes to em-dash, how to disable?

Postby zac » Tue Jan 18, 2011 8:22 pm

Right-click on the input field, in the 'Substitutions' submenu.

danteand
Harmless
Posts: 8
Joined: Mon Jan 03, 2005 10:22 am

Re: 2 dashes to em-dash, how to disable?

Postby danteand » Tue Jan 18, 2011 8:38 pm

Thank you.

For anyone doing a search in the future, the option to turn off is labeled "Smart Dashes"


Return to “Adium”

Who is online

Users browsing this forum: No registered users