Adium fails to connect to AIM behind firewall

An instant messenger which can connect to AIM, GTalk, Jabber, ICQ, and more.
Posts: 3
Joined: Sun Mar 16, 2014 3:17 pm

Adium fails to connect to AIM behind firewall

Postby haggerty » Sun Mar 16, 2014 3:39 pm


I'm using Adium 1.5.9 (the latest available) on OS X 10.9.2 to connect to an AIM account. It works beautifully almost everywhere--planes, trains, coffee shops, at home--but at my place of work, it stopped being able to connect to AIM a couple of months ago when they reconfigured the IP space used on the internal wireless network. Now, whenever I try to connect to AIM on that network, I get a message

"You have been connecting and disconnecting too frequently. Wait ten minutes and try again. If you continue to try, you will need to wait even longer."

and in the account dialog, I see "Connection reset by peer." I have turned off the firewall on my Mac, and it makes no difference. I tried a variety of altered configurations, like ports other than 5190 on, to no avail.

It would seem to be clearly a firewall problem on the internal network, except that I recently realized that the official AOL AIM client connects just fine. Also, pidgin on a Windows machine on the internal wireless network seemed to connect without any problem. So it would seem that Adium tries to make some connection that AIM itself doesn't. I believe my employer would fix it if I could tell them what to change, because I think it is not blocked by design. I tried to test the protocol manually with "telnet 5190" and as far as I can see, I get the same prompt back at work that I do at home, so that does not seem to be blocked. I tried Wireshark'ing the connection so I could see what was going on, but it looks too complicated for me to reverse engineer the entire protocol.

I see that I can build pidgin for the Mac with homebrew, and I'll try that when I get a chance, but can someone describe what needs to work for the AIM connection to work? What ports to what domains? Are there any DNS oddities?

Adium is a nice piece of software which I like, but this really prevents me from enjoying it on a daily basis. Thanks in advance for any hints.

Posts: 3
Joined: Sun Mar 16, 2014 3:17 pm

Re: Adium fails to connect to AIM behind firewall

Postby haggerty » Thu Mar 20, 2014 1:54 pm

I tried Adium 1.5.10b1 and I have the same problem, but I can see the debug window, and to a non-expert, it looks ok until this happens:

Code: Select all

09:47:53: ************ xxx --step-- 3
09:47:53: (Libpurple: dnsquery) IP resolved for
09:47:53: (Libpurple: proxy) Attempting connection to
09:47:53: (Libpurple: proxy) Connecting to with no proxy
09:47:53: (Libpurple: proxy) Connection in progress
09:47:53: (Libpurple: proxy) Connecting to
09:47:53: (Libpurple: proxy) Connected to
09:47:53: (Libpurple: oscar) connected to FLAP server of type 0x0002
09:47:53: Connecting: gc=0x2a5e80 (Connection established, cookie sent) 4 / 6
09:47:53: ************ xxx --step-- 4
09:47:53: (Libpurple: oscar) Scheduling destruction of FLAP connection 0x6000001d3ce0 of type 0x0002
09:47:53: (Libpurple: oscar) Destroying FLAP connection 0x6000001d3ce0
09:47:53: (Libpurple: oscar) Destroying oscar connection (0x6000001d3ce0) of type 0x0002.  Disconnect reason is 4
09:47:53: (Libpurple: oscar) Disconnected.  Code is 0x0000 and msg is Connection reset by peer
09:47:53: (Libpurple: connection) Connection error on 0x6000002a5e80 (reason: 0 description: Lost connection with server: Connection reset by peer)
09:47:53: Connection Disconnected: gc=2a5e80 (Lost connection with server: Connection reset by peer)
09:47:53: <ESPurpleAIMAccount:4a08ed0 1>:xxx accountConnectionReportDisconnect: Lost connection with server: Connection reset by peer
09:47:53: (Libpurple: account) Disconnecting account xxx (0x60000014a2f0)
09:47:53: (Libpurple: connection) Disconnecting connection 0x6000002a5e80
09:47:53: (Libpurple: oscar) Signed off.
09:47:53: Disconnected: gc=2a5e80

That "Disconnect reason is 4" looks bad to me.

Also, I now know that pidgin built out of Homebrew, connects fine on this network.

Return to “Adium”

Who is online

Users browsing this forum: No registered users