writing two "-"

An instant messenger which can connect to AIM, GTalk, Jabber, ICQ, and more.
Post Reply
arek
Harmless
Posts: 7
Joined: Wed Oct 16, 2019 5:53 am

writing two "-"

Post by arek »

When writing two "-" like "--" adium replaces it with unicode "—". How to disable this ugly behaviour?
User avatar
Robby
Cocoaforge Admin
Posts: 2610
Joined: Mon May 01, 2006 3:00 am

Re: writing two "-"

Post by Robby »

Yes, double hyphens are being converted to em dashes (—). This is a part of macOS' "text replacement" functionality and not something that Adium specifically does. This macOS feature works across most programme on your Mac.

You can turn this off globally, that is for all programmes on your Mac, or only for specific programmes such as Adium. See the section "Use smart quotes and dashes" at https://support.apple.com/en-gb/guide/m ... h35735/mac for details.
arek
Harmless
Posts: 7
Joined: Wed Oct 16, 2019 5:53 am

Re: writing two "-"

Post by arek »

Right click in adium -> substitutions -> uncheck smart dashes worked. Thanks! That was annoying feature (not only in adium but also in terminal).
User avatar
weriusaa
Latté
Posts: 79
Joined: Mon Dec 03, 2007 9:11 pm

Re: writing two "-"

Post by weriusaa »

Thanks for the information. I have been writing a lot of research and essays at university lately. Sometimes this is quite difficult, so I turn for help to the service https://www.rush-my-essay.com/write-my- ... rch-paper/ Sometimes it is difficult for me to write a research paper due to lack of literature and sources.
Post Reply