Adium crashing each time

An instant messenger which can connect to AIM, GTalk, Jabber, ICQ, and more.
johnc8117
Harmless
Posts: 6
Joined: Sat Sep 17, 2005 9:11 pm

Adium crashing each time

Postby johnc8117 » Sat Sep 17, 2005 9:16 pm

Hi there

I love Adium. I've used it for months and months. A strange thing started happening today whenever I get a message in or try to type one to someone else it crashes. I'm using the latest version too. Any idea how I can track down what might be causing this?

Thanks

John

User avatar
evands
Cocoaforge Admin
Posts: 3152
Joined: Thu Dec 02, 2004 10:55 pm
Location: Decatur, GA
Contact:

Postby evands » Sat Sep 17, 2005 9:19 pm

What's the email address on your crash reports?
The duck still burns.
--
My company: Saltatory Software. Check it out :)

johnc8117
Harmless
Posts: 6
Joined: Sat Sep 17, 2005 9:11 pm

Postby johnc8117 » Sat Sep 17, 2005 10:16 pm

hi there. johnc8117@yahoo.com

Thanks

J

User avatar
evands
Cocoaforge Admin
Posts: 3152
Joined: Thu Dec 02, 2004 10:55 pm
Location: Decatur, GA
Contact:

Postby evands » Sat Sep 17, 2005 10:35 pm

We don't have any crash reports submitted under that name. Perhaps you used a different one?
The duck still burns.

--

My company: Saltatory Software. Check it out :)

johnc8117
Harmless
Posts: 6
Joined: Sat Sep 17, 2005 9:11 pm

Postby johnc8117 » Sat Sep 17, 2005 10:41 pm

Strange, just tried again and checked the email address. Can you check now?

johnc8117
Harmless
Posts: 6
Joined: Sat Sep 17, 2005 9:11 pm

Postby johnc8117 » Sat Sep 17, 2005 10:45 pm

I took a copy of the info and pasted it below:

OS Version: Version 10.4.2 (Build 8C46)
Language: English
Exception: NSInvalidArgumentException
Reason: *** -[NSCFArray addObject:]: attempt to insert nil
Stack trace:
1
2 +[NSException raise:format:] (in Foundation)
3
4 -[NSCFArray addObject:] (in Foundation)
5
6 -[NSSpellChecker init] (in AppKit)
7
8 +[NSSpellChecker sharedSpellChecker] (in AppKit)
9
10 -[NSTextView(NSSharing) _preflightSpellChecker:] (in AppKit)
11
12 ___NSFireDelayedPerform (in Foundation)
13
14 ___CFRunLoopDoTimer (in CoreFoundation)
15

User avatar
evands
Cocoaforge Admin
Posts: 3152
Joined: Thu Dec 02, 2004 10:55 pm
Location: Decatur, GA
Contact:

Postby evands » Sat Sep 17, 2005 11:36 pm

There's one in there now -- not sure what was up before :)

I imaginge you're getting Console logging (/Applications/Utilities/Console.app) as you use other apps... say TextEdit.. and they may be functioning oddly. The systemwide spell checker is performing an illegal operation... has anything changed with your system? Spell checking dictionaries, language / international changes, etc?
The duck still burns.

--

My company: Saltatory Software. Check it out :)

katsu
Harmless
Posts: 2
Joined: Sun Sep 18, 2005 2:00 am

Mine is strange, too

Postby katsu » Sun Sep 18, 2005 2:12 am

My adium has been acting up since I downloaded the new version. I love it and it has never given me problems before. Now whenever I log on and someone sends me a message, adium freezes up. The color wheel (that shows it's thinking) won't stop. I can go to other programs and use them, but adium just keeps thinking.

User avatar
Githon
Frappa
Posts: 162
Joined: Sun Dec 05, 2004 1:03 am

Postby Githon » Sun Sep 18, 2005 3:28 am

You KNOW something's gotta be seriously wrong if the spell check is broken.

Everyone knows the spell check function is the heart of every OS.

User avatar
evands
Cocoaforge Admin
Posts: 3152
Joined: Thu Dec 02, 2004 10:55 pm
Location: Decatur, GA
Contact:

Re: Mine is strange, too

Postby evands » Sun Sep 18, 2005 4:11 am

katsu wrote:My adium has been acting up since I downloaded the new version. I love it and it has never given me problems before. Now whenever I log on and someone sends me a message, adium freezes up. The color wheel (that shows it's thinking) won't stop. I can go to other programs and use them, but adium just keeps thinking.

Please see http://trac.adiumx.com/wiki/ReportingBugs
The duck still burns.

--

My company: Saltatory Software. Check it out :)

User avatar
Adam Iser
Crema
Posts: 427
Joined: Thu Dec 02, 2004 1:36 am

Re: Mine is strange, too

Postby Adam Iser » Sun Sep 18, 2005 4:13 am

evands wrote:
katsu wrote:My adium has been acting up since I downloaded the new version. I love it and it has never given me problems before. Now whenever I log on and someone sends me a message, adium freezes up. The color wheel (that shows it's thinking) won't stop. I can go to other programs and use them, but adium just keeps thinking.

Please see http://trac.adiumx.com/wiki/ReportingBugs


Specifically http://trac.adiumx.com/wiki/TroubleshootingTips - the section about removing 3rd party addons.

User avatar
evands
Cocoaforge Admin
Posts: 3152
Joined: Thu Dec 02, 2004 10:55 pm
Location: Decatur, GA
Contact:

Re: Mine is strange, too

Postby evands » Sun Sep 18, 2005 4:24 am

Adam Iser wrote:
evands wrote:
katsu wrote:My adium has been acting up since I downloaded the new version. I love it and it has never given me problems before. Now whenever I log on and someone sends me a message, adium freezes up. The color wheel (that shows it's thinking) won't stop. I can go to other programs and use them, but adium just keeps thinking.

Please see http://trac.adiumx.com/wiki/ReportingBugs


Specifically http://trac.adiumx.com/wiki/TroubleshootingTips - the section about removing 3rd party addons.

Ah, right. Specifically, remove Pushpin :) (There's a fixed version of it available from adiumxtras.com)
The duck still burns.

--

My company: Saltatory Software. Check it out :)

katsu
Harmless
Posts: 2
Joined: Sun Sep 18, 2005 2:00 am

it's working

Postby katsu » Sun Sep 18, 2005 6:08 am

I deleted pushpin, and now it's just dandy. Thanks.

Yay for adium

johnc8117
Harmless
Posts: 6
Joined: Sat Sep 17, 2005 9:11 pm

Postby johnc8117 » Sun Sep 18, 2005 6:54 am

hi

I downloaded the latest XCode (v 2.1) from Apple and installed it. Thats the only thing I've done recently. Could this be causing it? I've tried restarting and ensuring no other software is open. Any suggestions on how I can track it down and solve it?

Thanks

J

johnc8117
Harmless
Posts: 6
Joined: Sat Sep 17, 2005 9:11 pm

UPDATE: FIXED

Postby johnc8117 » Sun Sep 18, 2005 8:34 am

What an idiot I am!! :) I forgot that yesterday I plugged my wifes PowerBook G4 in via Firewire to backup her whole system as hers was an earlier one without the DVD Writer. Needless to say I copied her OS9 and the very first OS X over to my machine and I'm sure Adium was picking up files from there. I removed it and Adium works fine now.

Thanks for the help - thought I'd explain that it was my fault :)

J

User avatar
evands
Cocoaforge Admin
Posts: 3152
Joined: Thu Dec 02, 2004 10:55 pm
Location: Decatur, GA
Contact:

Re: UPDATE: FIXED

Postby evands » Sun Sep 18, 2005 1:25 pm

johnc8117 wrote:What an idiot I am!! :) I forgot that yesterday I plugged my wifes PowerBook G4 in via Firewire to backup her whole system as hers was an earlier one without the DVD Writer. Needless to say I copied her OS9 and the very first OS X over to my machine and I'm sure Adium was picking up files from there. I removed it and Adium works fine now.

Thanks for the help - thought I'd explain that it was my fault :)

J

Cool :)
The duck still burns.

--

My company: Saltatory Software. Check it out :)


Return to “Adium”

Who is online

Users browsing this forum: Google [Bot]