Connection loss in AIM

An instant messenger which can connect to AIM, GTalk, Jabber, ICQ, and more.
Post Reply
CardboardBox
Harmless
Posts: 2
Joined: Thu Aug 10, 2006 1:35 am

Connection loss in AIM

Post by CardboardBox »

If my internet connection flickers off for some reason, as one might expect, my instant messenger connections over Adium are lost. What is unexpected to me, though, is that for an AIM account, Adium may go nearly twenty minutes before it realizes that the connection to AIM has been lost. Meanwhile, I can be sending messages to contacts and they might be likewise sending messages to me, but these messages are never received. Yahoo and GTalk accounts seem to notice the loss of connection instantly, and I've found the same problem with AIM over iChat, so the problem is most likely with AIM. Nonetheless, this problem causes enough miscommunications that I figured I'd ask here whether anyone has any suggestions on how to deal with this aside from convincing my friends to switch services.

I've tested this on MacOS X 10.3.9 using Adium 0.89.1 and 1.0b8. My apologies if this has been posted before. A search didn't seem to turn anything up.
YiddishSoul
Harmless
Posts: 1
Joined: Thu Mar 29, 2007 9:24 am
Location: Austin, TX

Bump?

Post by YiddishSoul »

Hi, I was wondering if anyone had any advice for this person's situation. I have the exact same problem. It's very awkward to send an important message, get no reply, then have to ask if they actually got it. Thanks in advance!
Zeremus X
Crema
Posts: 297
Joined: Sat Aug 20, 2005 2:08 pm
Location: Maryland
Contact:

Post by Zeremus X »

One thing you can try is looking at someones "profile" or info and see if anything loads up. If it doesnt then that normally means AIM isnt connected. I think theres an option to check where it reconnects Adium after a connection loss. It sounds like you already have but its worth a shot. Hope this helps you guys. :)
CardboardBox
Harmless
Posts: 2
Joined: Thu Aug 10, 2006 1:35 am

Post by CardboardBox »

In my case, I ended up figuring out what was causing my connection to go out all the time. I'm embarrassed to admit this, but it was going out every time I connected or disconnected from a VPN, and it took me months to figure that out.

Having said that, I think the newer versions of Adium (since switching back to libgaim in the 1.0 betas) are better at detecting a disconnection. It doesn't seem to take more than 10 seconds.
Post Reply