Bug: "Customize Toolbar ..." not working (2501)

An RSS/Atom newsreader with features comparable to commercial newsreaders.
User avatar
Robby
Cocoaforge Admin
Posts: 2606
Joined: Mon May 01, 2006 3:00 am

Re: Bug: "Customize Toolbar ..." not working (2501)

Postby Robby » Tue Mar 30, 2010 9:24 am

Have you got machines running Leopard? Is the Console error relevant and helpful? Would a debug log help?

Creativegeek
Harmless
Posts: 9
Joined: Tue Mar 09, 2010 9:44 pm

Re: Bug: "Customize Toolbar ..." not working (2501)

Postby Creativegeek » Tue Mar 30, 2010 5:43 pm

This prob doesn't help but I upgraded my second machine running 10.5.8 to 2501 and none of the toolbar works..I can change Icon and text and remove items from the toolbar but can not add anything nor do the buttons on the toolbar work at all. I can click on any button on the toolbar and NOTHING happens, well nothing visible anyway :D

Is there any logs I can post for you guys that might help??

Cheers

nirvana11
Harmless
Posts: 4
Joined: Sun Oct 08, 2006 6:24 pm
Location: Italy

Re: Bug: "Customize Toolbar ..." not working (2501)

Postby nirvana11 » Fri Apr 02, 2010 9:09 am

Hi guys, i have the same problem too with OSX 10.5.8, Italian localization.
Anyone solved this problem?
Thanks.
Attilio from Italy.
Ciao.
Attilio.

dirt farmer
Latté
Posts: 94
Joined: Tue Apr 08, 2008 10:25 pm

Re: Bug: "Customize Toolbar ..." not working (2501)

Postby dirt farmer » Sat Apr 03, 2010 10:57 pm

Just to bump-up what Robby asked...

surely one of the developers is running Leopard somewhere, no? Not even off a Time Machine restore?? Color me perplexed!

Can you see anything at all useful in the .console log?

User avatar
Michael Ströck
Vienna Team
Posts: 303
Joined: Mon Mar 06, 2006 9:21 am
Location: Vienna, Austria
Contact:

Re: Bug: "Customize Toolbar ..." not working (2501)

Postby Michael Ströck » Sun Apr 04, 2010 3:39 am

dirt farmer wrote:Just to bump-up what Robby asked...

surely one of the developers is running Leopard somewhere, no? Not even off a Time Machine restore?? Color me perplexed!

Can you see anything at all useful in the .console log?


I can't speak for the others, but I don't have one. Working without the actual bug to look at, I haven't found a solution yet.

loopkid
Harmless
Posts: 10
Joined: Tue Nov 27, 2007 2:30 am

Re: Bug: "Customize Toolbar ..." not working (2501)

Postby loopkid » Mon Apr 05, 2010 7:58 pm

A workaround for adding buttons is opening the Vienna preferences in the Property List Editor and adding a new item to TB Item Identifiers in NSToolbar Configuration MA_Toolbar.

stennie
Harmless
Posts: 1
Joined: Wed Apr 07, 2010 7:13 am

Re: Bug: "Customize Toolbar ..." not working (2501)

Postby stennie » Wed Apr 07, 2010 7:52 am

I don't think this problem is specific to Leopard .. I've just had the same problem with Vienna 2.5.0.2501 on Snow Leopard 10.6.3.

Can't recall the last time I tried to customise the toolbar, but I did have a custom toolbar from older Vienna (2.4 .. didn't try the 2.5 beta).

I had similar problems to those described in the original post for this topic:
- I choose "Customize Toolbar" from the right-click context menu on the toolbar
- the toolbar was editable but I couldn't see the property sheet with extra commands/icons to choose from
- I had to quit and restart Vienna to get out of the toolbar edit mode
- after a restart I tried again and was able to successfully run the "customise toolbar"

However .. I tried to edit again and the property sheet is no longer showing :(. Console log includes a specific exception whenever I try to customise the toolbar .. info attached.

Cheers,
Stephen
Attachments
vienna-noedit.txt
Info from Console messages searching on "vienna" after exception occurs.
(4.44 KiB) Downloaded 314 times

dirt farmer
Latté
Posts: 94
Joined: Tue Apr 08, 2008 10:25 pm

Re: Bug: "Customize Toolbar ..." not working (2501)

Postby dirt farmer » Mon May 17, 2010 11:03 pm

Has there been any progress on this issue?

p.s., where's Michael Ströck been lately?

dirt farmer
Latté
Posts: 94
Joined: Tue Apr 08, 2008 10:25 pm

Re: Bug: "Customize Toolbar ..." not working (2501)

Postby dirt farmer » Tue May 25, 2010 1:07 am

Jeesh! Don't all shout at once. I'll assume no progress is being made on this issue. :???:

Oh, well....

maybe someday...

User avatar
Sequoyah
Harmless
Posts: 4
Joined: Wed Feb 25, 2009 5:28 am

Re: Bug: "Customize Toolbar ..." not working (2501)

Postby Sequoyah » Sun Jun 27, 2010 7:02 am

Bump

Still having the same issue. Has there been any further word on this?
Image

stevepa
Vienna Team
Posts: 469
Joined: Fri Jan 13, 2006 3:13 pm

Re: Bug: "Customize Toolbar ..." not working (2501)

Postby stevepa » Fri May 13, 2011 3:24 am

OK - going to take a look at this one for build 2502 even though I can't reproduce it using any of the repro steps mentioned in this thread. Sorry for the delay - as you've surmised, we've all been off doing other things.

stevepa
Vienna Team
Posts: 469
Joined: Fri Jan 13, 2006 3:13 pm

Re: Bug: "Customize Toolbar ..." not working (2501)

Postby stevepa » Fri May 13, 2011 3:59 am

The attached log suggests where the problem may lay:

<Warning>: CGSResolveShmemReference : window.RO : Reference offset (39040) exceeds bounds (32768) on shmem obj 0x185b

It looks distinctly like a memory corruption bug. At the time the problem is happening, the Mac OSX Toolbox is attempting to draw the toolbar customization sheet and failing either there or shortly afterwards because it detected memory inconsistency. I've seen that particular error mentioned in the context of failing physical RAM but I can imagine that a latent memory bug in Vienna itself may ultimately give rise to this. Quite possibly there's a set of circumstances that cause it to trigger only when the toolbar is being edited.

So a good first step would be for me to turn on the memory checking in XCode and run Vienna for a while and see if I can reproduce a case where it is doing something bad with memory. I can't promise that this will be an easy fix but I'll do my best. The lack of a solid repro will always be the killer here since it is hard to validate a fix for something that doesn't actually break for me.

User avatar
Robby
Cocoaforge Admin
Posts: 2606
Joined: Mon May 01, 2006 3:00 am

Re: Bug: "Customize Toolbar ..." not working (2501)

Postby Robby » Fri May 13, 2011 9:17 am

Yay! =-)

dirt farmer
Latté
Posts: 94
Joined: Tue Apr 08, 2008 10:25 pm

Re: Bug: "Customize Toolbar ..." not working (2501)

Postby dirt farmer » Wed May 18, 2011 11:36 pm

Have you found anything yet, Steve?

stevepa
Vienna Team
Posts: 469
Joined: Fri Jan 13, 2006 3:13 pm

Re: Bug: "Customize Toolbar ..." not working (2501)

Postby stevepa » Sat Jun 11, 2011 1:35 am

No, sorry. Still trying but this is a tough one. I'll need to think of a different approach but without a consistent repro, it is going to be hard to debug.

User avatar
Michael Ströck
Vienna Team
Posts: 303
Joined: Mon Mar 06, 2006 9:21 am
Location: Vienna, Austria
Contact:

Re: Bug: "Customize Toolbar ..." not working (2501)

Postby Michael Ströck » Tue Aug 02, 2011 12:00 am

Try as I might, I cannot reproduce this... This is now off my list, unfortunately...

mcbakewl
Harmless
Posts: 3
Joined: Sat Nov 05, 2011 10:46 pm

Re: Bug: "Customize Toolbar ..." not working (2501)

Postby mcbakewl » Sat Nov 05, 2011 10:53 pm

I'd like to put a "Send to Pukka" button in my toolbar but Vienna's "Customize Toolbar" does not appear to be working. There's a "Customize Toolbar" View Menu item but selecting it does nothing at all. Apparently this is neither unheard of, nor the way it should be. Console messages appended.

MacBook Pro - early 2009
OS X 10.5.8
Vienna Version 2.5.1.2502

With thanks,

-- Mac

Code: Select all

11/05/2011 02:41:08 PM Vienna[10960] Schau: Search all articles
11/05/2011 02:42:20 PM Vienna[10960] *** -[AppController encodeWithCoder:]: unrecognized selector sent to instance 0x265c80
11/05/2011 02:42:20 PM Vienna[10960] *** -[AppController encodeWithCoder:]: unrecognized selector sent to instance 0x265c80
11/05/2011 02:42:28 PM Vienna[10960] *** -[AppController encodeWithCoder:]: unrecognized selector sent to instance 0x265c80
11/05/2011 02:42:28 PM Vienna[10960] *** -[AppController encodeWithCoder:]: unrecognized selector sent to instance 0x265c80
11/05/2011 02:42:54 PM Vienna[10960] *** -[AppController encodeWithCoder:]: unrecognized selector sent to instance 0x265c80
11/05/2011 02:42:54 PM Vienna[10960] *** -[AppController encodeWithCoder:]: unrecognized selector sent to instance 0x265c80
11/05/2011 02:45:00 PM [0x0-0xb30b3].uk.co.opencommunity.vienna2[10960] Vienna[10960]: [FM] Called insert with return 0
11/05/2011 02:45:01 PM [0x0-0xb30b3].uk.co.opencommunity.vienna2[10960] Vienna[10960]: [FM] Called insert with return 0
11/05/2011 02:45:50 PM [0x0-0xb30b3].uk.co.opencommunity.vienna2[10960] Vienna[10960]: [FM] Called insert with return 0
11/05/2011 02:45:50 PM [0x0-0xb30b3].uk.co.opencommunity.vienna2[10960] Vienna[10960]: [FM] Called insert with return 0
11/05/2011 02:45:56 PM [0x0-0xb30b3].uk.co.opencommunity.vienna2[10960] Vienna[10960]: [FM] Called insert with return 0
11/05/2011 02:45:56 PM [0x0-0xb30b3].uk.co.opencommunity.vienna2[10960] Vienna[10960]: [FM] Called insert with return 0
11/05/2011 02:53:50 PM [0x0-0xb30b3].uk.co.opencommunity.vienna2[10960] Vienna[10960]: [FM] Called insert with return 0
11/05/2011 02:53:50 PM [0x0-0xb30b3].uk.co.opencommunity.vienna2[10960] Vienna[10960]: [FM] Called insert with return 0
11/05/2011 02:53:57 PM Vienna[10960] A regular control size progress indicator <PSMProgressIndicator: 0x25e4a0f0> with the frame size for small control size detected.  Please use -setControlSize: to explicitly specify NSSmallControlSize
11/05/2011 02:54:16 PM [0x0-0xb30b3].uk.co.opencommunity.vienna2[10960] Vienna[10960]: [FM] Called insert with return 0
11/05/2011 02:54:16 PM [0x0-0xb30b3].uk.co.opencommunity.vienna2[10960] Vienna[10960]: [FM] Called insert with return 0
11/05/2011 02:57:11 PM Vienna[11237] Schau: Search all articles
11/05/2011 02:57:52 PM [0x0-0xbd0bd].uk.co.opencommunity.vienna2[11237] Vienna[11237]: [FM] Called insert with return 0
11/05/2011 02:57:52 PM [0x0-0xbd0bd].uk.co.opencommunity.vienna2[11237] Vienna[11237]: [FM] Called insert with return 0
11/05/2011 03:01:34 PM Vienna[11237] A regular control size progress indicator <PSMProgressIndicator: 0x1ee862d0> with the frame size for small control size detected.  Please use -setControlSize: to explicitly specify NSSmallControlSize
11/05/2011 03:02:25 PM Vienna[11237] *** -[AppController encodeWithCoder:]: unrecognized selector sent to instance 0x2cf6d0
11/05/2011 03:02:25 PM Vienna[11237] *** -[AppController encodeWithCoder:]: unrecognized selector sent to instance 0x2cf6d0
11/05/2011 03:02:34 PM Vienna[11237] *** -[AppController encodeWithCoder:]: unrecognized selector sent to instance 0x2cf6d0
11/05/2011 03:02:34 PM Vienna[11237] *** -[AppController encodeWithCoder:]: unrecognized selector sent to instance 0x2cf6d0
11/05/2011 03:27:33 PM [0x0-0xbd0bd].uk.co.opencommunity.vienna2[11237] Vienna[11237]: [FM] Called insert with return 0
11/05/2011 03:27:33 PM [0x0-0xbd0bd].uk.co.opencommunity.vienna2[11237] Vienna[11237]: [FM] Called insert with return 0
11/05/2011 03:27:38 PM Vienna[11237] *** -[AppController encodeWithCoder:]: unrecognized selector sent to instance 0x2cf6d0
11/05/2011 03:27:38 PM Vienna[11237] *** -[AppController encodeWithCoder:]: unrecognized selector sent to instance 0x2cf6d0
11/05/2011 03:27:39 PM [0x0-0xbd0bd].uk.co.opencommunity.vienna2[11237] Vienna[11237]: [FM] Called insert with return 0
11/05/2011 03:27:39 PM [0x0-0xbd0bd].uk.co.opencommunity.vienna2[11237] Vienna[11237]: [FM] Called insert with return 0

dirt farmer
Latté
Posts: 94
Joined: Tue Apr 08, 2008 10:25 pm

Re: Bug: "Customize Toolbar ..." not working (2501)

Postby dirt farmer » Sun Nov 06, 2011 1:09 am

The toolbar problem seems to be localized to Leopard. When I upgraded to Snow Leopard awhile back, all was well.

mcbakewl
Harmless
Posts: 3
Joined: Sat Nov 05, 2011 10:46 pm

Re: Bug: "Customize Toolbar ..." not working (2501)

Postby mcbakewl » Sun Nov 06, 2011 3:34 pm

OK. This is definitely a Leopard thing. The good news is that tweaked Vienna prefs moved from a Snow Leopard machine retain all of their toolbar settings on the Leopard machine. So now I've got Vienna with a Pukka button on Leopard.


Return to “Vienna”

Who is online

Users browsing this forum: No registered users