Vienna 3.6.0 is our current recommendation

An RSS/Atom newsreader with features comparable to commercial newsreaders.
barijaona
Vienna Team
Posts: 643
Joined: Sat Nov 12, 2011 11:10 am
Contact:

Vienna 3.6.0 is our current recommendation

Postby barijaona » Sat Jul 08, 2017 5:50 am

[Updated on November 12th, 2020]
Vienna 3.6.0 is out.

All users are advised to use this version (runs from macOS 10.11 to macOS 11). Natively supports machines based on Apple Silicon processors.

OS X 10.9 or 10.10 users should use version 3.5.10 of Vienna

Latest "stable" release of Vienna can always be found at https://github.com/ViennaRSS/vienna-rss/releases/latest
All recent versions of Vienna are visible at https://github.com/ViennaRSS/vienna-rss/releases
I contribute to Vienna RSS as a developer.
Please, don't forget those tips for writing a good bug report

philmur
Harmless
Posts: 2
Joined: Sun Feb 16, 2020 4:52 am

Re: Vienna 3.5.6 is our current recommendation

Postby philmur » Thu Aug 13, 2020 3:50 pm

If Vienna 3.5.6 crashes on startup, when 3.5.5 does not, this fix worked for me.

In Terminal:

Code: Select all

echo 'pragma main.user_version=21;' | sqlite3 ~/'Library/Application Support/Vienna/messages.db'

These crashes (or sometimes hangs) have happened on every Vienna update since 2.0.9. They may have to do with the size of my messages.db file (250k+ messages, 615MB). Incrementing main.user_version fixed the crash problem every time.
Last edited by philmur on Thu Aug 13, 2020 4:29 pm, edited 1 time in total.


Return to “Vienna”

Who is online

Users browsing this forum: Google Feedfetcher