Subtitles on Quicktime

The Perian forums have moved to Google Groups, this forum is read only.
Locked
hardback
Harmless
Posts: 3
Joined: Fri Jun 10, 2011 6:14 pm

Subtitles on Quicktime

Post by hardback »

I just recently upgraded to Mac OS X Snow Leopard, but I'm facing serious problems with viewing Quicktime movies with subtitles. In some videos, when the Movie Property for subtitles is checked, the subtitles are the only thing shown on a black screen, and there should be actual footage under it. In other videos, the screen only turns black when just the subtitles are being shown. Could anyone please help me with this issue?
gbooker
Cocoaforge Admin
Posts: 723
Joined: Sat May 06, 2006 2:47 am
Contact:

Re: Subtitles on Quicktime

Post by gbooker »

Instead of repeating the answer again, I'm going to tell you to try the search function.
hardback
Harmless
Posts: 3
Joined: Fri Jun 10, 2011 6:14 pm

Re: Subtitles on Quicktime

Post by hardback »

I'm sorry but I couldn't find a good answer to my question, because most of them had to do with a program called Front Row, and I'm not as concerned with that as I am with Quicktime.
hardback
Harmless
Posts: 3
Joined: Fri Jun 10, 2011 6:14 pm

Re: Subtitles on Quicktime

Post by hardback »

I created an account on this forum just so that I could get an answer to this "black screen on Quicktime" question. I don't use Front Row, and everything I see online regarding this problem mentions Front Row, and I'm only concerned about the same problem on Quicktime 7 Player for Mac OS X Snow Leopard. So could someone out there please give me some assistance??
dinamasu
Harmless
Posts: 2
Joined: Tue Jul 26, 2011 2:21 pm

Re: Subtitles on Quicktime

Post by dinamasu »

I am having the same problem of QT 7.6.9 and Perian 1.2.3 using Mac OSX 10.5.8.

It seems that the latest upgrade form Perian 1.2.2 to Perian 1.2.3 "messed up" the process.

Things were working fine until this latest version of Perian.
dinamasu
Harmless
Posts: 2
Joined: Tue Jul 26, 2011 2:21 pm

Re: Subtitles on Quicktime

Post by dinamasu »

dinamasu wrote:I am having the same problem of QT 7.6.9 and Perian 1.2.3 using Mac OSX 10.5.8.

It seems that the latest upgrade form Perian 1.2.2 to Perian 1.2.3 "messed up" the process.

Things were working fine until this latest version of Perian.
Instead of "Restoring" Perian 1.2.2 which I had done previously. I found a download site for Perian 1.2.2 and Removed Perian, then I installed Perian 1.2.2 from the "fresh" download.
Everything is now working as before. I can view and Toast soft subtitle (.srt files) and the subtitles will appear on the resulting dvd when "Toast"ed.

All is well for my particular configuration ans .avi files.
Mr VacBob
Crema
Posts: 330
Joined: Thu Jan 04, 2007 11:14 pm
Contact:

Re: Subtitles on Quicktime

Post by Mr VacBob »

I can't reproduce this on 10.7. A 10.5-only problem would be annoying since I don't have the tools to rebuild a release for it at this point.

Does this happen with just avi+srt, or also with MKV with embedded subtitles?
User avatar
The_Tick
Cocoaforge Admin
Posts: 4642
Joined: Thu Dec 02, 2004 6:06 am
Contact:

Re: Subtitles on Quicktime

Post by The_Tick »

Mr VacBob wrote:I can't reproduce this on 10.7. A 10.5-only problem would be annoying since I don't have the tools to rebuild a release for it at this point.

Does this happen with just avi+srt, or also with MKV with embedded subtitles?
Aye. At some point we'll have to cut 10.5 off, maybe 1.2.2 will be that cutoff point with this one.
Locked