Page 1 of 1

Crypto::SSLeay install problem

Posted: Sun Mar 04, 2012 3:00 pm
by teedjack

I realise this is technically related to CPAN, but seeing as this is a step in levying, I hoped others here would have experienced this and have a solution to hand.


Code: Select all

sudo cpan install Crypto::SSLeay

on my Mac mini running 10.7.3, CPAN complains:

Code: Select all

No installed SSL libraries found in any of the following places.
You will have to either specify a directory location at the following
prompt, or rerun the Makefile.PL program and use the --lib switch
to specify the path. If the path in question is considered standard
on your platform, please consider filing a bug report in order to
have it taken into account in a subsequent version of Crypt::SSLeay.

Found multiple possibilities for OpenSSL
Which SSL install path do you want to use?

Can someone give me the required path to use? This is a near-fresh, barely-touched install of 10.7.3.

Re: Crypto::SSLeay install problem

Posted: Sun Mar 04, 2012 3:44 pm
by zac
(Update: SSLeay is not required in Lion.)

Apple deprecated OpenSSL support on 10.7, which has has the unfortunate effect here of breaking the script. I'm not sure if there's an easy fix, but you may consider using `growlnotify` to trigger Prowl notifications, or removing the SSL support from the script.

Re: Crypto::SSLeay install problem

Posted: Sun Mar 04, 2012 6:36 pm
by teedjack
Thanks zac. Are there plans to provide a script implementing SSL that will work with 10.7 onwards?

In the meantime, that's another reason for me to avoid upgrading the rest of my Macs to Lion. :(

Re: Crypto::SSLeay install problem

Posted: Wed Mar 07, 2012 3:26 pm
by teedjack

I've just tried to install the script on Snow Leopard, and run into the exact same problems.

Look, no offence, but when did you actually last test the install procedure for Macs? It appears to be terribly out of date.

One glaring error is the fact that the command you request Mac users run:
sudo cpan install Crypt::SSLeay
is itself wrong. CPAN immediately comes up with an error telling you to use:
sudo cpan Crypt::SSLeay

Please, update your documentation to reflect the fact that installing on a Mac may not be as straight-forward as on LINUX etc. In fact, it may not be possible without some serious tweaking.



Re: Crypto::SSLeay install problem

Posted: Thu Mar 08, 2012 12:14 am
by zac
The command is correct, and the install works successfully when it can find openssl. I see no "run without 'install'" errors on either OS. Note that you quoted the incorrect command in your first post. It is "Crypt" not "Crypto". When I tried this, CPAN provided a nice helper output correcting the typo. I expect this is what you saw.

I just tested the script on Lion and it works without needing to install Crypt::SSLeay, so it will work without needing to do anything special. I will update the FAQ to note it is not needed in Lion.

If you have any other errors, please include the error logs, etc., in this thread.