GrowlMail not working in 1.1.3

The Growl forums have moved to Google Groups, this forum is read only.
charlesarthur
Muffin
Posts: 28
Joined: Fri Nov 02, 2007 1:18 pm
Contact:

GrowlMail not working in 1.1.3

Postby charlesarthur » Mon May 19, 2008 4:06 pm

So I'm trying out 1.1.3b4. Uninstalled 1.1.2. Installed 1.1.3b4.
Have only installed Growl for myself.
Installed GrowlMail (pan-users). Mail was quit and restarted. Bundle is in the correct place. It's the correct GrowlMail (not old version hanging around.), creation date 13 May 08.
Growlmail showing up in the list of apps in Growl Prefpane. Is enabled for new mail, not for junk.

But it doesn't notify. I know messages are coming in - there's the ping in the background.
Other Growl notifications are working.
Troubleshooting suggestions, please?

User avatar
excomax
Frappa
Posts: 126
Joined: Tue Apr 24, 2007 2:22 am
Location: Leipzig (Germany)
Contact:

Re: GrowlMail not working in 1.1.3

Postby excomax » Tue May 20, 2008 8:10 am

Is it activated in the Mail Prefs?

charlesarthur
Muffin
Posts: 28
Joined: Fri Nov 02, 2007 1:18 pm
Contact:

Re: GrowlMail not working in 1.1.3

Postby charlesarthur » Tue May 20, 2008 3:19 pm

excomax wrote:Is it activated in the Mail Prefs?


... it is now.. [slinks away]
In (weak) self-defence, the installer notes (the ReadMe) doesn't say it needs activating in the Prefs. Worth adding?

charlesarthur
Muffin
Posts: 28
Joined: Fri Nov 02, 2007 1:18 pm
Contact:

Re: GrowlMail not working in 1.1.3

Postby charlesarthur » Tue May 20, 2008 4:55 pm

..and having quit Mail and restarted it, that works. Hurrah! Amendments to GrowlMail ReadMes all round! (suggested serving.)

jalperin
Harmless
Posts: 3
Joined: Tue May 20, 2008 9:24 pm

Re: GrowlMail not working in 1.1.3

Postby jalperin » Tue May 20, 2008 9:27 pm

I am having the same problem. Except that I cannot activate it in the preferences. For some reason, I cannot get the preferences to appear in Mail.

I have Mail.app 3.2
The bundle gets installed (I can see the folder in /Library/Mail/Bundles)
Nothing appears in the Growl PrefPane

Any ideas?

I had given up on this and I am using an Apple Script. But it'd be nice to have it working with GrowlMail, so I can configure the Junk and have the right icon in m notification.

Thanks!

User avatar
The_Tick
Cocoaforge Admin
Posts: 4642
Joined: Thu Dec 02, 2004 6:06 am
Contact:

Re: GrowlMail not working in 1.1.3

Postby The_Tick » Tue May 20, 2008 10:37 pm

charlesarthur wrote:
excomax wrote:Is it activated in the Mail Prefs?


... it is now.. [slinks away]
In (weak) self-defence, the installer notes (the ReadMe) doesn't say it needs activating in the Prefs. Worth adding?


Nah, there are two arrows, and the growlmail page indicates that you need to look at this as well. I've thought of throwing the readme out and putting a webloc to the online docs in there instead though

charlesarthur
Muffin
Posts: 28
Joined: Fri Nov 02, 2007 1:18 pm
Contact:

Re: GrowlMail not working in 1.1.3

Postby charlesarthur » Wed May 21, 2008 1:48 pm

The_Tick wrote:[Nah, there are two arrows, and the growlmail page indicates that you need to look at this as well. I've thought of throwing the readme out and putting a webloc to the online docs in there instead though


I'm pretty sure the two of us have been here before.
Personally, I don't follow weblocs, because I'm not always online when I finally come to install stuff; and because ReadMes are always going to be there, and because weblocs (other peoples', of course) are often just bits of self-aggrandisement with no useful stuff.

One thing about the Mail Prefs in Leopard is that they don't offer a resize box and it's not obvious that there are prefs "off the side", unless you pay careful attention to the (not very obvious) double arrows. And even then, if GrowlMail is there in the Prefs, one might assume it was enabled.

As PT Barnum would have said, nobody ever got a support call by underestimating the stupidity of the average user. Putting it in the GrowlMail readme and on the page won't kill electrons unnecessarily, and will mean you can say "We told you here *and* here."

User avatar
The_Tick
Cocoaforge Admin
Posts: 4642
Joined: Thu Dec 02, 2004 6:06 am
Contact:

Re: GrowlMail not working in 1.1.3

Postby The_Tick » Fri May 23, 2008 2:51 pm

It also means we have to maintain and make sure both are synced, which obviously hasn't been happening for a while.

I don't agree that the arrows are not obvious, they are standardized across all of os x. If you feel that they are though, you should probably file a radar with apple.

jalperin
Harmless
Posts: 3
Joined: Tue May 20, 2008 9:24 pm

Re: GrowlMail not working in 1.1.3

Postby jalperin » Fri May 23, 2008 6:28 pm

Anybody have any idea why the pref pane might not be showing up in Mail? even after the restart.

mattrobs
Harmless
Posts: 17
Joined: Thu Dec 20, 2007 1:16 am

Re: GrowlMail not working in 1.1.3

Postby mattrobs » Sat May 24, 2008 4:12 am

^ What he said.

Anita Easton
Harmless
Posts: 5
Joined: Sat Apr 05, 2008 1:23 am

Re: GrowlMail not working in 1.1.3

Postby Anita Easton » Sat May 24, 2008 5:21 am

Me too :)

I've installed the current beta, then GrowlMail. The bundle is in place and correctly dated but growl doesn't appear in the Mail Preferences. I've tried a couple of restarts and so on, no joy.

Incidentally, you can resize the mail preferences window in the signature tab (but not any other one), so I'm sure it's not there :)

Anita

P.S. This beta is not locking up my System Preferences - many thanks!!

Ancyru
Harmless
Posts: 9
Joined: Wed Jul 04, 2007 5:50 pm
Location: .au
Contact:

Re: GrowlMail not working in 1.1.3

Postby Ancyru » Tue May 27, 2008 1:22 am

This work around indeed helped me enable the preference pane in Mail. I'm unsure if it's just this application that helped out, WideMail but it worked & that's all that matters.

I installed this application which enabled a preference pane for its own application but in doing so revealed the preference pane for GrowlMail! I then uninstalled WideMail & GrowlMail remains & works perfectly.

Perhaps the people coding Growl could check into this? For some reason it's not enabling the preference pane for some of us.
When I get sad, I stop being sad, and be AWESOME instead. True story.
Image

jalperin
Harmless
Posts: 3
Joined: Tue May 20, 2008 9:24 pm

Re: GrowlMail not working in 1.1.3

Postby jalperin » Wed May 28, 2008 4:21 pm

yup! that did it. installing widemail and then uninstalling it enabled the prefpane.

how odd. great find, thanks.

Anita Easton
Harmless
Posts: 5
Joined: Sat Apr 05, 2008 1:23 am

Re: GrowlMail not working in 1.1.3

Postby Anita Easton » Sun Jun 01, 2008 11:16 pm

Installing and uninstalling widemail worked for me too – growl is now in my Mail preferences, which means it's now working :)

Anita

sfaguy
Harmless
Posts: 2
Joined: Thu Jun 05, 2008 7:03 am

Re: GrowlMail not working in 1.1.3

Postby sfaguy » Thu Jun 05, 2008 7:07 am

i installed widemail and then 1.1.3, it works fine now.

thank you for sharing the tips with widemail.

Stern
Muffin
Posts: 45
Joined: Fri Feb 03, 2006 11:44 am

Re: GrowlMail not working in 1.1.3

Postby Stern » Sat Jun 07, 2008 9:02 am

After installation of GrowlMail the EnableBundles default was zero. Manually issuing the command "defaults write com.apple.mail EnableBundles -bool YES" fixed that, and GrowlMail works now.

Lars
Muffin
Posts: 34
Joined: Wed Mar 22, 2006 6:05 pm

Re: GrowlMail not working in 1.1.3

Postby Lars » Sat Jun 07, 2008 9:20 am

Thanks Stern! This fixed it for me! :razz:

Tsaxman28
Harmless
Posts: 1
Joined: Sat Jun 07, 2008 12:08 pm

Re: GrowlMail not working in 1.1.3

Postby Tsaxman28 » Sat Jun 07, 2008 5:27 pm

Stern wrote:After installation of GrowlMail the EnableBundles default was zero. Manually issuing the command "defaults write com.apple.mail EnableBundles -bool YES" fixed that, and GrowlMail works now.


This worked with me as well. Thanks.

wade
Harmless
Posts: 1
Joined: Sat Jun 07, 2008 11:54 pm

Re: GrowlMail not working in 1.1.3

Postby wade » Sat Jun 07, 2008 11:59 pm

Hmm, I'm not having success getting the pref pane to show in Mail even after trying both the WideMail and the defaults tricks. Any ideas?

Thanks in advance, -Wade

rocketmouse
Harmless
Posts: 3
Joined: Fri Jun 13, 2008 8:04 pm

Re: GrowlMail not working in 1.1.3

Postby rocketmouse » Fri Jun 13, 2008 8:26 pm

Using the WideMail install/uninstall worked for me too (thanks Ancyru,) but I'm puzzled as to why the coders haven't reacted yet. There seems to be a fair number of us with this problem. On the other hand, you get what you pay for... :mrgreen:
-rocketmouse
MacBook1,1 - Intel Core Duo 2 GHz, 2 GB DDR2 SDRAM


Return to “Growl”

Who is online

Users browsing this forum: No registered users