Page 1 of 1

Problem with growl and skype

Posted: Tue Aug 04, 2009 11:37 am
by fred_zhuzhu
I searched on this forum for a similar problem, I found the hint :

defaults write com.skype.skype SKUseGrowl -bool TRUE

it works for everything except incoming call :/

I use the lastest growl and Skype 2.8.

Anyone get the same issue ?

Re: Problem with growl and skype

Posted: Tue Aug 04, 2009 4:30 pm
by boredzo
Skype has its own floating Smoke-looking dialog box for incoming calls, which doesn't go through Growl. It wouldn't surprise me if it doesn't support posting a Growl notification alongside the Skype floating dialog box.

Re: Problem with growl and skype

Posted: Wed Aug 12, 2009 12:57 am
by rrao
I also seem to have this problem. Other skype notifications for growl work except for incoming call. Have upgraded to Skype 2.8 and 1.1.6. Have also done the 'defaults write com.skype.skype.plist' but no dice. Any help is most appreciated. Thanks.

Re: Problem with growl and skype

Posted: Wed Aug 12, 2009 1:01 am
by boredzo
rrao wrote:I also seem to have this problem. Other skype notifications for growl work except for incoming call.


Is there an incoming call notification? Skype has its own notification-like dialog box for that, so it wouldn't surprise me if it doesn't post it to Growl.

Have also done the 'defaults write com.skype.skype.plist' but no dice.


That's because that's not the correct domain.

Re: Problem with growl and skype

Posted: Wed Aug 12, 2009 1:11 am
by rrao
Thanks for the prompt response.

Ok. So doing this is not possible at all?

Re: Problem with growl and skype

Posted: Wed Aug 12, 2009 1:32 am
by boredzo
rrao wrote:So doing this is not possible at all?


It is possible. Run the correct defaults command as given earlier in this thread.

I don't know whether Growl notifications for incoming calls are possible or not, having not used Skype for several versions.

Re: Problem with growl and skype

Posted: Wed Aug 12, 2009 1:36 am
by rrao
I did run the correct defaults command and also looked in the .plist file.It does appear to have set the SKUseGrowl to True.

Re: Problem with growl and skype

Posted: Wed Aug 12, 2009 1:38 am
by boredzo
Check whether there's an incoming call notification in Skype's listing in the Growl preference pane in System Preferences. If so, make sure that notification is enabled.

Re: Problem with growl and skype

Posted: Wed Aug 12, 2009 2:34 am
by rrao
I have checked the notifications and those appear to be identical to other ones such as for Chat messages in Skype. Those work fine with Growl.

As you suspect, this could likely be due to the prowl-like notification in Skype when there is an incoming call. I have posted to the Skype forums as well and hope that a reply will be forthcoming but am not counting on it.

Re: Problem with growl and skype

Posted: Thu Aug 13, 2009 8:57 pm
by rrao
I have tried everything possible to try to get it to work but it all fails. I have uninstalled and reinstalled both Skype and Growl. I do have the correct defaults write command but this does not work. Every other Skype notification works fine except the Incoming call one.

Does anyone have this working with Skype 2.8.0.659 and Growl 1.1.6? I am also using a Macbook running 10.5.7.

Thanks in advance for your help.

Re: Problem with growl and skype

Posted: Thu Aug 13, 2009 9:03 pm
by boredzo
rrao wrote:I do have the correct defaults write command but this does not work. Every other Skype notification works fine except the Incoming call one.


That hidden pref controls all of Skype's usage of Growl, so if you're getting any Growl notifications from Skype at all, the pref is working.

Re: Problem with growl and skype

Posted: Thu Aug 13, 2009 9:10 pm
by rrao
boredzo wrote:
That hidden pref controls all of Skype's usage of Growl, so if you're getting any Growl notifications from Skype at all, the pref is working.


Thanks. Skype notifications work irrespective of that hidden pref. I have turned it off and on and even deleted it but the notifications work.

Re: Problem with growl and skype

Posted: Thu Aug 13, 2009 9:13 pm
by boredzo
rrao wrote:Skype notifications work irrespective of that hidden pref. I have turned it off and on and even deleted it but the notifications work.


Yay! Sounds like they realized that it caused nothing but user confusion.