GrowlMail not working in SL

The Growl forums have moved to Google Groups, this forum is read only.
edsilver
Harmless
Posts: 7
Joined: Fri Sep 25, 2009 4:18 pm

Re: GrowlMail not working in SL

Postby edsilver » Sun Sep 27, 2009 9:33 pm

Yes, simple notifier worked for me as well.

webmasttroy
Harmless
Posts: 4
Joined: Sun Sep 27, 2009 9:21 pm

Re: GrowlMail not working in SL

Postby webmasttroy » Sun Sep 27, 2009 9:34 pm

Simplest notifier worked for me also

pierodj
Harmless
Posts: 6
Joined: Sat Sep 26, 2009 8:36 am

Re: GrowlMail not working in SL

Postby pierodj » Sun Sep 27, 2009 9:51 pm

works for me too ;)

User avatar
boredzo
Cocoaforge Admin
Posts: 796
Joined: Mon Dec 06, 2004 7:49 am
Contact:

Re: GrowlMail not working in SL

Postby boredzo » Sun Sep 27, 2009 11:22 pm

BTW, b6 is now out, and I invite you all to see whether it works for you.

Even if it doesn't, I can't think of any other things to try, so unless one of you finds the cause on your own, 1.2 will just have to have whatever bug (if it is a Growl or GrowlMail bug) you all are experiencing.

webmasttroy
Harmless
Posts: 4
Joined: Sun Sep 27, 2009 9:21 pm

Re: GrowlMail not working in SL

Postby webmasttroy » Sun Sep 27, 2009 11:44 pm

Still not showing Growl messages on new emails and GrowlMail still isn't showing in the Growl > Applications list with 1.2b6. :(

broken_chaos
Harmless
Posts: 14
Joined: Sat Jun 20, 2009 7:03 am

Re: GrowlMail not working in SL

Postby broken_chaos » Sun Sep 27, 2009 11:49 pm

This seems like it's the same problem I (and some others) were experiencing with GrowlSafari (and, in my case, other Growl-bundled apps). If you want, you can try installing the b4 version of GrowlMail only, and then updating GrowlMail to b6. If it works after doing that, it's the same issue with the applications not properly registering when they're using the b5 or b6 version of Growl.framework.

webmasttroy
Harmless
Posts: 4
Joined: Sun Sep 27, 2009 9:21 pm

Re: GrowlMail not working in SL

Postby webmasttroy » Sun Sep 27, 2009 11:57 pm

broken_chaos wrote:This seems like it's the same problem I (and some others) were experiencing with GrowlSafari (and, in my case, other Growl-bundled apps). If you want, you can try installing the b4 version of GrowlMail only, and then updating GrowlMail to b6. If it works after doing that, it's the same issue with the applications not properly registering when they're using the b5 or b6 version of Growl.framework.

Growl 1.2b6 with GrowlMail 1.2b4 worked. GrowlMail shows up in the Applications list and the messages pop up.

Thanks!

broken_chaos
Harmless
Posts: 14
Joined: Sat Jun 20, 2009 7:03 am

Re: GrowlMail not working in SL

Postby broken_chaos » Mon Sep 28, 2009 12:02 am

webmasttroy wrote:Growl 1.2b6 with GrowlMail 1.2b4 worked. GrowlMail shows up in the Applications list and the messages pop up.

You should be able to upgrade it to the b6 version now, if you want. The bug only seems to crop up when registering (meaning before it's on the Applications list), so since GrowlMail is already there, the newer version should work too.

webmasttroy
Harmless
Posts: 4
Joined: Sun Sep 27, 2009 9:21 pm

Re: GrowlMail not working in SL

Postby webmasttroy » Mon Sep 28, 2009 12:05 am

broken_chaos wrote:
webmasttroy wrote:Growl 1.2b6 with GrowlMail 1.2b4 worked. GrowlMail shows up in the Applications list and the messages pop up.

You should be able to upgrade it to the b6 version now, if you want. The bug only seems to crop up when registering (meaning before it's on the Applications list), so since GrowlMail is already there, the newer version should work too.


I tried that initially and it didn't work but doing it again now seems to be working OK. I must not have installed/opened things in the right order to get it to register correctly. Anyway, 1.2b6 w/ both Growl and GrowlMail are working for me now. Thanks again!

edsilver
Harmless
Posts: 7
Joined: Fri Sep 25, 2009 4:18 pm

Re: GrowlMail not working in SL

Postby edsilver » Mon Sep 28, 2009 12:11 am

Also confirmed that 1.2b6 Growl with 1.2b4 GrowlMail works. Not sure why that combo is registering and the others are not, but glad to have it working.

Let me know if you want further help debugging to get 1.2b6 working in full.

Regards,

Ed

cue180
Harmless
Posts: 3
Joined: Sat Sep 26, 2009 6:56 pm

Re: GrowlMail not working in SL

Postby cue180 » Mon Sep 28, 2009 12:32 am

yes..installed 1.2b4 growlmail with 1.2b6 growl & it showed up in the applications list..then i upgraded to 1.2b6 growlmail & it still works

thanks

User avatar
boredzo
Cocoaforge Admin
Posts: 796
Joined: Mon Dec 06, 2004 7:49 am
Contact:

Re: GrowlMail not working in SL

Postby boredzo » Mon Sep 28, 2009 12:33 am

As broken_chaos noted, the bug only affects registering. So if you went back to b4, it successfully registered, and that continues to apply after you upgrade to b6. (Not sure why it didn't apply the first time. That logic may be worth revisiting at some point.)

Anyway, I'm closing in on the problem and will have b7 sometime tonight (tomorrow at the latest) with a fix.

User avatar
boredzo
Cocoaforge Admin
Posts: 796
Joined: Mon Dec 06, 2004 7:49 am
Contact:

Re: GrowlMail not working in SL

Postby boredzo » Mon Sep 28, 2009 7:47 am

boredzo wrote:Anyway, I'm closing in on the problem and will have b7 sometime tonight (tomorrow at the latest) with a fix.


OK, a bit of both, as it's three quarters past midnight here.

So, all of you: Please try beta 7 and let us know whether that works.

somin
Harmless
Posts: 1
Joined: Mon Sep 28, 2009 8:29 am

Re: GrowlMail not working in SL

Postby somin » Mon Sep 28, 2009 8:35 am

boredzo, the b7 GrowlMail finally works (as i had the same registration problem).
thx so much for your efforts!

edt: Oh and I didn't install b4 first btw...

pierodj
Harmless
Posts: 6
Joined: Sat Sep 26, 2009 8:36 am

Re: GrowlMail not working in SL

Postby pierodj » Tue Sep 29, 2009 7:03 pm

installed growl 1.2 final, works great!

thanks, boredzo :grin:

JonathanW
Harmless
Posts: 14
Joined: Sun Apr 06, 2008 6:14 pm
Location: Newcastle, UK

Re: GrowlMail not working in SL

Postby JonathanW » Tue Sep 29, 2009 9:51 pm

As pierodj mentioned above, GrowlMail is working properly now, thanks! :)

wisemagic
Harmless
Posts: 2
Joined: Wed Sep 30, 2009 1:07 am

Re: GrowlMail not working in SL

Postby wisemagic » Wed Sep 30, 2009 1:14 am

Hi, I have installed and uninstalled the GrowlMail pkg. The bundle is not in ~/Library/Mail/Bundles. I have not been able to locate it anywhere. GrowlMail doesn't show up Mail Preferences, and Mail doesn't show in Growl Preferences application list. The installer seems to indicate that the install has no errors. I do not have any other plugins or bundles for Mail. Any suggestions?

wisemagic
Harmless
Posts: 2
Joined: Wed Sep 30, 2009 1:07 am

Re: GrowlMail not working in SL

Postby wisemagic » Wed Sep 30, 2009 1:25 am

This is the install log....

9/29/09 12:50:20 PM Installer[844] GrowlMail Installation Log
9/29/09 12:50:20 PM Installer[844] Opened from: /Volumes/Growl-1.2/Extras/GrowlMail/GrowlMail.pkg
9/29/09 12:50:35 PM Installer[844] Install: "GrowlMail"
9/29/09 12:50:35 PM Installer[844] Install: "GrowlMail" at path "//tmp/GrowlMail-Installation-Temp"
9/29/09 12:50:36 PM installd[854] using receipt prefix of tmp/GrowlMail-Installation-Temp
9/29/09 12:50:37 PM installd[854] Installed "GrowlMail" ()
9/29/09 1:00:51 PM installd[1171] Installed "GrowlMail" ()
9/29/09 8:18:52 PM Installer[4125] GrowlMail Installation Log
9/29/09 8:18:52 PM Installer[4125] Opened from: /Volumes/Growl-1.2/Extras/GrowlMail/GrowlMail.pkg
9/29/09 8:19:03 PM Installer[4125] Install: "GrowlMail"
9/29/09 8:19:03 PM Installer[4125] Install: "GrowlMail" at path "//tmp/GrowlMail-Installation-Temp"
9/29/09 8:19:03 PM installd[4135] using receipt prefix of tmp/GrowlMail-Installation-Temp
9/29/09 8:19:05 PM installd[4135] Installed "GrowlMail" ()
9/29/09 8:19:48 PM Installer[4185] GrowlMail Installation Log
9/29/09 8:19:48 PM Installer[4185] Opened from: /Volumes/Growl-1.2/Extras/GrowlMail/GrowlMail.pkg
9/29/09 8:20:01 PM Installer[4185] Upgrade: "GrowlMail"
9/29/09 8:20:01 PM Installer[4185] Upgrade: "GrowlMail" at path "//tmp/GrowlMail-Installation-Temp"
9/29/09 8:20:02 PM installd[4190] using receipt prefix of tmp/GrowlMail-Installation-Temp
9/29/09 8:20:03 PM installd[4190] Installed "GrowlMail" ()

edmartin
Harmless
Posts: 1
Joined: Wed Sep 30, 2009 11:35 am

Re: GrowlMail not working in SL

Postby edmartin » Wed Sep 30, 2009 11:39 am

I used Growl under Leopard but did not use any of the betas under Snow Leopard. When I installed SL, I didn't do an update - I wiped my machine and installed it as a brand new machine. In other words, I did a fresh install of 1.2 yesterday on what is effectively a brand new Mac (in terms of OS).

Growl Mail is not working for me. I have tried the various things suggested in this thread. No luck.

The only wrinkle is that I have the Letterbox plugin installed for Mail.app.

wishta@comcast.net
Harmless
Posts: 1
Joined: Wed Sep 30, 2009 11:40 am

Re: GrowlMail not working in SL

Postby wishta@comcast.net » Wed Sep 30, 2009 11:44 am

I have Mac OS 10.6 on a Macbook Pro and I get an error when opening mail. I have deleted and reinstalled Growl 1.2 several times and nothing removes removes the following error:

Mail has disabled the following plug-ins:
GrowlMail
Contact the makers of these plug-ins for versions that are compatible with Mail 4.1 and Message 4.1


I been to the user/library/mail/mailbundle, etc..... nothing there to delete.

There is no growl tab in mail either.

Help


Return to “Growl”

Who is online

Users browsing this forum: No registered users