Growl 1.2 Released Sept 28th! Or not?

The Growl forums have moved to Google Groups, this forum is read only.
ooglek
Harmless
Posts: 8
Joined: Tue Aug 26, 2008 9:31 pm

Growl 1.2 Released Sept 28th! Or not?

Postby ooglek » Tue Sep 29, 2009 3:22 am

Timezones aside... ;-)

I saw a few rumblings that 1.2 was out today (Sept 28th). And granted, in my timezone, there are still 41 minutes left of the 28th!!! So maybe I'm just an impatient bastard not paying a dime for fantastical software.

But I thought I'd ask. It's fine with me if it isn't gonna happen today, I understand how difficult it is to fix all the moving parts AND release software that so many rely upon. Would love an update. Because I'm an impatient bastard software leech. :mrgreen:

I do realize the effort that goes into Growl and the other fine software that is created here, so kudos and thank you for your generous giving of your time and talents.

User avatar
boredzo
Cocoaforge Admin
Posts: 796
Joined: Mon Dec 06, 2004 7:49 am
Contact:

Re: Growl 1.2 Released Sept 28th! Or not?

Postby boredzo » Tue Sep 29, 2009 3:34 am

Yes, 1.2 will be tonight.

ooglek
Harmless
Posts: 8
Joined: Tue Aug 26, 2008 9:31 pm

Re: Growl 1.2 Released Sept 28th! Or not?

Postby ooglek » Tue Sep 29, 2009 7:34 am

Awesome! Just updated, it's sooo nice to have it working well (at least it is right now) again.

Thank you boredzo and the other devs!

User avatar
boredzo
Cocoaforge Admin
Posts: 796
Joined: Mon Dec 06, 2004 7:49 am
Contact:

Re: Growl 1.2 Released Sept 28th! Or not?

Postby boredzo » Tue Sep 29, 2009 7:35 am

You're welcome. ☺

corcho
Harmless
Posts: 7
Joined: Tue Sep 29, 2009 7:35 am

Re: Growl 1.2 Released Sept 28th! Or not?

Postby corcho » Tue Sep 29, 2009 7:38 am

Hi! I've installed Growl 1.2 in my Mac, but when I start Apple Mail it's still showing the notice that "Growl mail is incompatible...bla..bla..".
Any suggestions?

Thanks!

User avatar
boredzo
Cocoaforge Admin
Posts: 796
Joined: Mon Dec 06, 2004 7:49 am
Contact:

Re: Growl 1.2 Released Sept 28th! Or not?

Postby boredzo » Tue Sep 29, 2009 7:46 am

corcho wrote:I've installed Growl 1.2 in my Mac, but when I start Apple Mail it's still showing the notice that "Growl mail is incompatible...bla..bla..".


Installing Growl does not update GrowlMail (or any of the other Extras). You need to update GrowlMail as well.

corcho
Harmless
Posts: 7
Joined: Tue Sep 29, 2009 7:35 am

Re: Growl 1.2 Released Sept 28th! Or not?

Postby corcho » Tue Sep 29, 2009 9:04 am

Thanks Boredzo, but I've also installed the Growlmail.pkg . What I'm doing wrong?

Thanks in advance!

User avatar
boredzo
Cocoaforge Admin
Posts: 796
Joined: Mon Dec 06, 2004 7:49 am
Contact:

Re: Growl 1.2 Released Sept 28th! Or not?

Postby boredzo » Tue Sep 29, 2009 9:05 am

corcho wrote:Thanks Boredzo, but I've also installed the Growlmail.pkg . What I'm doing wrong?


Try running Uninstall GrowlMail, then reinstalling.

corcho
Harmless
Posts: 7
Joined: Tue Sep 29, 2009 7:35 am

Re: Growl 1.2 Released Sept 28th! Or not?

Postby corcho » Tue Sep 29, 2009 9:20 am

I did it! But nothing happens!

Thanx

User avatar
boredzo
Cocoaforge Admin
Posts: 796
Joined: Mon Dec 06, 2004 7:49 am
Contact:

Re: Growl 1.2 Released Sept 28th! Or not?

Postby boredzo » Tue Sep 29, 2009 9:21 am

corcho wrote:I did it! But nothing happens!


Open ~/Library/Mail/Bundles/GrowlMail.mailbundle/Contents/Info.plist. What version number do you see there?

Also, what version of Mac OS X are you using?

corcho
Harmless
Posts: 7
Joined: Tue Sep 29, 2009 7:35 am

Re: Growl 1.2 Released Sept 28th! Or not?

Postby corcho » Tue Sep 29, 2009 9:25 am

version="1.0" encoding="UTF-8
I'm using MacOS Snow Leopard 10.6.1

Thanks!

User avatar
boredzo
Cocoaforge Admin
Posts: 796
Joined: Mon Dec 06, 2004 7:49 am
Contact:

Re: Growl 1.2 Released Sept 28th! Or not?

Postby boredzo » Tue Sep 29, 2009 9:33 am

corcho wrote:version="1.0" encoding="UTF-8


That's the version of the property list format, not the version of GrowlMail.

corcho
Harmless
Posts: 7
Joined: Tue Sep 29, 2009 7:35 am

Re: Growl 1.2 Released Sept 28th! Or not?

Postby corcho » Tue Sep 29, 2009 9:37 am

Ok, I'm sorry! Here's the list:
<key>CFBundleDevelopmentRegion</key>
<string>English</string>
<key>CFBundleExecutable</key>
<string>GrowlMail</string>
<key>CFBundleIdentifier</key>
<string>com.growl.GrowlMail</string>
<key>CFBundleInfoDictionaryVersion</key>
<string>6.0</string>
<key>CFBundlePackageType</key>
<string>BNDL</string>
<key>CFBundleShortVersionString</key>
<string>1.1.3</string>
<key>CFBundleSignature</key>
<string>emal</string>
<key>CFBundleVersion</key>
<string>1.1.3</string>
<key>NSPrincipalClass</key>
<string>GrowlMail</string>

User avatar
boredzo
Cocoaforge Admin
Posts: 796
Joined: Mon Dec 06, 2004 7:49 am
Contact:

Re: Growl 1.2 Released Sept 28th! Or not?

Postby boredzo » Tue Sep 29, 2009 9:43 am

Yeah, you definitely need to run the GrowlMail uninstaller.

Please let us know if the .mailbundle is still there after you run the uninstaller but before you open the Installer package.

corcho
Harmless
Posts: 7
Joined: Tue Sep 29, 2009 7:35 am

Re: Growl 1.2 Released Sept 28th! Or not?

Postby corcho » Tue Sep 29, 2009 9:49 am

Ok, I've done but GrowMail.mailbundle is still there!


Tx

corcho
Harmless
Posts: 7
Joined: Tue Sep 29, 2009 7:35 am

Re: Growl 1.2 Released Sept 28th! Or not?

Postby corcho » Tue Sep 29, 2009 9:58 am

I've deleted the folder GrowMail.mailbundle, then I re-installed growmail, and the problem is solved!!

Thank you!!

User avatar
The_Tick
Cocoaforge Admin
Posts: 4642
Joined: Thu Dec 02, 2004 6:06 am
Contact:

Re: Growl 1.2 Released Sept 28th! Or not?

Postby The_Tick » Tue Sep 29, 2009 10:58 pm

Were you running Mail while you ran the uninstaller?

snkhan
Harmless
Posts: 11
Joined: Tue Jul 07, 2009 11:19 pm

Re: Growl 1.2 Released Sept 28th! Or not?

Postby snkhan » Tue Sep 29, 2009 11:55 pm

1.2 update went without a hitch, however installing growlnotify never seems to install the manual. Calling growlnotify from terminal works, so I'm unsure why the installer does not install the manual (by the way, I installed growlnotify by ./install.sh).

Thank you :)

User avatar
boredzo
Cocoaforge Admin
Posts: 796
Joined: Mon Dec 06, 2004 7:49 am
Contact:

Re: Growl 1.2 Released Sept 28th! Or not?

Postby boredzo » Wed Sep 30, 2009 3:29 am

snkhan wrote:1.2 update went without a hitch, however installing growlnotify never seems to install the manual.


It does, just not in the right place. For now, move it from /usr/local/man/man1, which is where our script installs it, to /usr/local/share/man/man1, which is the correct place.

snkhan
Harmless
Posts: 11
Joined: Tue Jul 07, 2009 11:19 pm

Re: Growl 1.2 Released Sept 28th! Or not?

Postby snkhan » Wed Sep 30, 2009 4:32 pm

Thanks for responding. Is there a safe way of doing this via CLI or otherwise? Not sure whether just moving this via finder is going to break anything (just in case the original path for the manual is set somewhere else).

Will the script be updated in the future to correct the location at which the manual is installed?

Thanks again.


Return to “Growl”

Who is online

Users browsing this forum: No registered users