Page 1 of 1

Cyberduck 2.8.5 suddenly stopped working

Posted: Mon Nov 16, 2009 3:06 pm
by sites4all
Mac OSX 10.3.9
Cyberduck 2.8.5 installed April 2008, has been working perfectly until today.
Now it crashes immediately after launch.

Crash report:
OS Version: 10.3.9 (Build 7W98)
Report Version: 2

Command: Cyberduck
Path: /Applications/Cyberduck/
Version: 2.8.5 (3611) (3611)
PID: 442
Thread: 0

Exception: EXC_BAD_ACCESS (0x0001)
Codes: KERN_INVALID_ADDRESS (0x0001) at 0x23332088

Thread 0 Crashed:
0 libobjc.A.dylib 0x90861204 objc_msgSend + 0x24
1 org.andymatuschak.Sparkle 0x00047fb0 -[SUAppcastItem minimumSystemVersion] + 0x24
2 org.andymatuschak.Sparkle 0x00044fa0 -[SUUpdater newVersionAvailable] + 0x30
3 org.andymatuschak.Sparkle 0x00045280 -[SUUpdater appcastDidFinishLoading:] + 0x284
4 0x90a4af80 __NSFireMainThreadPerform + 0x108
5 0x902151b0 __CFRunLoopPerformPerform + 0x88
6 0x901c4800 __CFRunLoopDoSources0 + 0x1fc
7 0x901c20b8 __CFRunLoopRun + 0x1b0
8 0x901c69e4 CFRunLoopRunSpecific + 0x148
9 0x92886e10 RunCurrentEventLoopInMode + 0xac
10 0x9288d4b4 ReceiveNextEventCommon + 0xf4
11 0x928af638 BlockUntilNextEventMatchingListInMode + 0x60
12 0x92e6c248 _DPSNextEvent + 0x180
13 0x92e82cc8 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 0x74
14 0x92e97048 -[NSApplication run] + 0x21c
15 0x92f53764 NSApplicationMain + 0x1d0
16 ch.sudo.cyberduck 0x00002c28 _start + 0x2f8
17 ch.sudo.cyberduck 0x0000292c start + 0x30
Java Crash log says:
The following error report describes the Java stack information at the crash.
The native stack information can be found in the crash log generated by CrashReporter.

An unexpected exception has been detected in native code outside the VM.
Unexpected Signal : Bus Error occurred at PC=0x908611F4

NOTE: We are unable to locate the function name symbol for the error
just occurred. Please refer to release documentation for possible
reason and solutions.
I've tried a re-install of Cyberduck to no avail. Any ideas???

Re: Cyberduck 2.8.5 suddenly stopped working

Posted: Mon Nov 16, 2009 3:46 pm
by sites4all
This is weird!
I just tried installing version 3.2.1 on another mac with OS 10.4.11 and got exactly the same problem...
EDIT: but after re-booting, it all worked OK (v3.2.1 on the second Mac, that is) Still got the original problem :(

Re: Cyberduck 2.8.5 suddenly stopped working

Posted: Mon Nov 16, 2009 5:34 pm
by sites4all

I ditched the preferences file and tried again, and blow me, it works! :grin:

Re: Cyberduck 2.8.5 suddenly stopped working

Posted: Mon Nov 16, 2009 5:46 pm
by dkocher
The issue is a bug in the Sparkle Updater framework shipped with these older versions of Cyberduck. When checking the minimum system requirement it crashes. The minimum system requirement was added to the update feed just recently because version 3.3 of Cyberduck requires OS X 10.5 or later. We will try to find a workaround on the server side.

In the meantime, it should be possible to turn the automatic update check off in the Preferences panel of Cyberduck (if you can reach this before it crashes) or entering in window

Code: Select all

defaults delete ch.sudo.cyberduck SUScheduledCheckInterval