Code Execution Vulnerability Found in Libpurple IM Library

An instant messenger which can connect to AIM, GTalk, Jabber, ICQ, and more.
decker12
Harmless
Posts: 2
Joined: Thu Mar 23, 2017 5:08 pm

Code Execution Vulnerability Found in Libpurple IM Library

Postby decker12 » Thu Mar 23, 2017 5:11 pm

Is there a path forward for Adium users considering this pretty serious security concern that was posted the other day? Can the devs comment on the availability or timing for a patch?

https://threatpost.com/code-execution-v ... ry/124448/
Last edited by Robby on Thu Mar 23, 2017 6:53 pm, edited 1 time in total.
Reason: No need for full text. People can click the link.

User avatar
Robby
Cocoaforge Admin
Posts: 2553
Joined: Mon May 01, 2006 3:00 am
Contact:

Re: Code Execution Vulnerability Found in Libpurple IM Library

Postby Robby » Thu Mar 23, 2017 6:53 pm

We're preparing a release. It's a matter of days.

decker12
Harmless
Posts: 2
Joined: Thu Mar 23, 2017 5:08 pm

Re: Code Execution Vulnerability Found in Libpurple IM Library

Postby decker12 » Thu Mar 23, 2017 6:55 pm

Awesome news! Thanks for the update and for the hard work you're putting into the new release!

User avatar
Robby
Cocoaforge Admin
Posts: 2553
Joined: Mon May 01, 2006 3:00 am
Contact:

Re: Code Execution Vulnerability Found in Libpurple IM Library

Postby Robby » Mon Mar 27, 2017 11:33 am

1.5.10.3 will address this issue and a beta is out: https://beta.adium.im Please test! =-)

Details in our blog post: https://adium.im/blog/2017/03/adium-1-5-10-3b1/


Return to “Adium”

Who is online

Users browsing this forum: Bing [Bot]